diff mbox series

[bug#73019,v2,2/3] gnu: Add vte-gtk-4-experimental-sixel.

Message ID c5cecb502c1059e3f6b0c9432e12e0a62dd60df1.1725523326.git.ashvithshetty10@gmail.com
State New
Headers show
Series Add Black Box terminal | expand

Commit Message

Ashvith Shetty Sept. 5, 2024, 8:27 a.m. UTC
* gnu/packages/crates-io.scm (vte-gtk-4-experimental-sixel-0.73.0): New public variable.

Change-Id: I4fabe33fa86d838a92040ac61f1cbd2277c91045
---
 gnu/packages/gnome.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 7339000436..99fb8487b9 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4666,6 +4666,27 @@  (define-public vte-with-gtk-4
     (propagated-inputs (modify-inputs (package-propagated-inputs vte)
                          (replace "gtk+" gtk)))))
 
+(define-public vte-gtk-4-experimental-sixel
+  (package/inherit vte-with-gtk-4
+    (name "vte-gtk4-experimental-sixel")
+    ;; this is the closest to v0.72.4 on the main branch
+    (version "0.73.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.gnome.org/GNOME/vte")
+                    (commit "aa7689792918a9d4054e367139d166b146a5bd22")))
+              (sha256 (base32
+                       "0cnccjylj5lbdi2igcd9277zslqrflzdpflngwkcxw4fiyxyv6gk"))))
+    (arguments (substitute-keyword-arguments (package-arguments vte-with-gtk-4)
+                 ((#:configure-flags flags
+                   #~'())
+                  #~(cons* "-Dsixel=true"
+                           #$flags))))
+    (propagated-inputs (modify-inputs (package-propagated-inputs
+                                       vte-with-gtk-4)
+                         (append libsixel)))))
+
 ;; Stable version for gtk2, required by gnurobots and lxterminal as of 2020-07.
 (define-public vte/gtk+-2
   (package (inherit vte)