diff mbox series

[bug#56041,v4] gnu: Add vkmark.

Message ID c56b4352ea644e4ffe2cbb1d20f2944366b005ff.1656343780.git.tj@schwi.pl
State New
Headers show
Series [bug#56041,v4] gnu: Add vkmark. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Tomasz Jeneralczyk June 27, 2022, 4:02 p.m. UTC
* gnu/packages/benchmark.scm (vkmark): Add variable.
---
On suggestion from IRC I:
 Rewrote the first comment to sound more professional
 Fixed description to not exceed fill-column on any given line
 Removed usage documentation from description

 gnu/packages/benchmark.scm | 48 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 48 insertions(+)


base-commit: b42e52a735722534cef53de874861a921b3d8734

Comments

\( Nov. 6, 2022, 9:40 a.m. UTC | #1
Heya,

On Mon Jun 27, 2022 at 5:02 PM BST, Tomasz Jeneralczyk wrote:
> * gnu/packages/benchmark.scm (vkmark): Add variable.

"New variable.", not "Add variable."

> --- a/gnu/packages/benchmark.scm
> +++ b/gnu/packages/benchmark.scm

> @@ -645,3 +652,44 @@ (define-public sysbench

> +        (revision "1"))

Use ``(revision "0")'' for the first version currently in Guix.

> +      (inputs (list vulkan-loader
> +                    vulkan-headers
> +                    glm
> +                    assimp
> +                    libxcb
> +                    xcb-util-wm
> +                    wayland-protocols
> +                    wayland))

There should be a newline between ``inputs'' and ``(list ...)''.

> +      (home-page "https://github.com/vkmark/vkmark")

home-page goes before synopsis.

    -- (
Tomasz Jeneralczyk Nov. 7, 2022, 3:31 p.m. UTC | #2
> There should be a newline between ``inputs'' and ``(list ...)''.
guix style positioned them on the same line. I feel like this tool gets
in the way more often than not.
\( Nov. 7, 2022, 5:07 p.m. UTC | #3
On Mon Nov 7, 2022 at 3:31 PM GMT, Tomasz Jeneralczyk wrote:
> guix style positioned them on the same line. I feel like this tool gets
> in the way more often than not.

Yup, so do I... Unfortunately it's not perfect for Guix packages in the wild yet.

    -- (
diff mbox series

Patch

diff --git a/gnu/packages/benchmark.scm b/gnu/packages/benchmark.scm
index f0e05483f0..0f33e5a0e3 100644
--- a/gnu/packages/benchmark.scm
+++ b/gnu/packages/benchmark.scm
@@ -11,6 +11,7 @@ 
 ;;; Copyright © 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2020 Greg Hogan <code@greghogan.com>
 ;;; Copyright © 2021 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2022 Tomasz Jeneralczyk <tj@schwi.pl>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -36,6 +37,7 @@  (define-module (gnu packages benchmark)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system python)
+  #:use-module (guix build-system meson)
   #:use-module (gnu packages)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
@@ -46,6 +48,9 @@  (define-module (gnu packages benchmark)
   #:use-module (gnu packages databases)
   #:use-module (gnu packages docbook)
   #:use-module (gnu packages kde-frameworks)
+  #:use-module (gnu packages freedesktop)
+  #:use-module (gnu packages gl)
+  #:use-module (gnu packages graphics)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages lua)
   #:use-module (gnu packages maths)
@@ -60,6 +65,8 @@  (define-module (gnu packages benchmark)
   #:use-module (gnu packages python-web)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages qt)
+  #:use-module (gnu packages vulkan)
+  #:use-module (gnu packages xorg)
   #:use-module (gnu packages xml)
   #:use-module (ice-9 match))
 
@@ -645,3 +652,44 @@  (define-public sysbench
 @item
 @end itemize")
     (license license:gpl2+)))
+
+(define-public vkmark
+  ;; The only ever release is tagged "2017.08" and as its name suggests
+  ;; it was back in the august of 2017. That version no longer compiles
+  ;; due to changes in APIs of its libraries.
+  ;; Latest commit on the other hand seems to be fully working on xcb
+  ;; and wayland backends.
+  (let ((commit "d872846e2e7c47010c11227eb713d00ccfdd35c6")
+        (revision "1"))
+    (package
+      (name "vkmark")
+      (version (git-version "2017.08" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/vkmark/vkmark")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0zlryz8i8jvl160bv30ig5nd9h4ahpjfw53ys839i41xi80jjg5d"))))
+      (build-system meson-build-system)
+      (native-inputs (list pkg-config))
+      ;; The kms back-end, as it is, seems to have bitrot
+      ;; and would need maintenance to work with current Mesa:
+      ;; https://gitlab.freedesktop.org/mesa/mesa/-/commit/5e6db1916806
+      (inputs (list vulkan-loader
+                    vulkan-headers
+                    glm
+                    assimp
+                    libxcb
+                    xcb-util-wm
+                    wayland-protocols
+                    wayland))
+      (synopsis "Extensible benchmarking suite for Vulkan")
+      (description
+       "vkmark offers a suite of scenes that can be used to measure various
+aspects of Vulkan performance.  The way in which each scene is rendered is
+configurable through a set of options.")
+      (home-page "https://github.com/vkmark/vkmark")
+      (license license:lgpl2.1+))))