[bug#62013] gnu: python-pypandoc: Upgrade to 1.7.5
Commit Message
The tests of python-pypandoc 1.6.5 fail; these are fixed in 1.7.5:
https://github.com/JessicaTegner/pypandoc/commit/6670e906dccaddcfcdec228e34e0eaffc20ae791
The tests of later versions of python-pypandoc also fail though:
https://github.com/JessicaTegner/pypandoc/pull/327
Finally, python-pypandoc requires the pandoc data to be embeded in
the binary:
https://github.com/jgm/pandoc/blob/main/INSTALL.md#creating-a-relocatable-binary
* gnu/packages/python-xyz.scm (python-pypandoc): Upgrade to 1.7.5
* gnu/packages/haskel-xyz.scm (pandoc): Embed data files.
---
gnu/packages/haskell-xyz.scm | 3 +++
gnu/packages/python-xyz.scm | 6 +++---
2 files changed, 6 insertions(+), 3 deletions(-)
base-commit: fd4545a47a527fff437abb9991156cfee4137d2b
Comments
Hi,
Hugo Buddelmeijer <hugo@buddelmeijer.nl> skribis:
> The tests of python-pypandoc 1.6.5 fail; these are fixed in 1.7.5:
> https://github.com/JessicaTegner/pypandoc/commit/6670e906dccaddcfcdec228e34e0eaffc20ae791
>
> The tests of later versions of python-pypandoc also fail though:
> https://github.com/JessicaTegner/pypandoc/pull/327
>
> Finally, python-pypandoc requires the pandoc data to be embeded in
> the binary:
> https://github.com/jgm/pandoc/blob/main/INSTALL.md#creating-a-relocatable-binary
>
> * gnu/packages/python-xyz.scm (python-pypandoc): Upgrade to 1.7.5
> * gnu/packages/haskel-xyz.scm (pandoc): Embed data files.
Applied, thanks!
It triggers ~830 package rebuilds, but it’s all been built on
qa.guix.gnu.org already and most of these are small packages anyway,
which is why I pushed it to ‘master’.
Ludo’.
@@ -8315,6 +8315,9 @@ (define-public pandoc
(name "pandoc")
(arguments
(list
+ ; Create entirely self-contained binary by embedding the data files
+ ; in the binary itself. Required for python-pypandoc.
+ #:configure-flags #~(list "-fembed_data_files")
#:phases
#~(modify-phases %standard-phases
(add-after 'register 'remove-libraries
@@ -27752,17 +27752,17 @@ (define-public python-safety
(define-public python-pypandoc
(package
(name "python-pypandoc")
- (version "1.6.4")
+ (version "1.7.5")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pypandoc" version))
(sha256
(base32
- "149basv4pvzg9zm74cjz68x8s2n5fykyj7prgysb0qfmja73r83f"))))
+ "0l6a8ngzpx363q2jskxxkx6psfhqrvc4js80dmn16r3vw6m2cb40"))))
(build-system python-build-system)
(inputs
- (list pandoc))
+ (list pandoc python-pandocfilters))
(propagated-inputs
`(("wheel" ,python-wheel)))
(native-inputs