diff mbox series

[bug#40439,1/3] gnu: Add libuv-static.

Message ID c509e6f1020750b3fe632ebe7a0e45f96b240a3b.camel@zrythm.org
State Work in progress
Headers show
Series [bug#40439,1/3] gnu: Add libuv-static. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou April 4, 2020, 9:08 p.m. UTC
Hi, 

This patch adds a static version of libuv (build with -fPIC) needed by
zynfusion.

Feel free to edit it as appropriate, I am not sure if this method of
doing it is acceptable.

Thanks,
Alex

Comments

Maxim Cournoyer Sept. 28, 2022, 8:33 p.m. UTC | #1
Hi,

Alexandros Theodotou <alex@zrythm.org> writes:

> Hi, 
>
> This patch adds a static version of libuv (build with -fPIC) needed by
> zynfusion.
>
> Feel free to edit it as appropriate, I am not sure if this method of
> doing it is acceptable.

It's possible to link static archives from shared objects built with
-fPIC; so I'd suggest doing:

--8<---------------cut here---------------start------------->8---
gnu: Add libuv-next.

* gnu/packages/libevent.scm (libuv-next): New variable.

1 file changed, 17 insertions(+)
gnu/packages/libevent.scm | 17 +++++++++++++++++

modified   gnu/packages/libevent.scm
@@ -133,6 +133,23 @@ (define-public libuv
     ;; details.  Documentation is CC-BY 4.0 as of 1.12.0; see 'LICENSE-docs'.
     (license (list expat cc-by4.0))))
 
+(define-public libuv-next
+  (package
+    (inherit libuv)
+    (name "libuv")
+    (version "1.44.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://dist.libuv.org/dist/v" version
+                                  "/libuv-v" version ".tar.gz"))
+              (sha256
+               (base32
+                "1d1wy1061cf2mfygr2j6jbm0da2mhsf0l9yq4rjkqrsmijbdrz6c"))))
+    (arguments
+     '(#:configure-flags '("--disable-static" "CFLAGS=-fPIC")
+       ;; XXX: Some tests want /dev/tty, attempt to make connections, etc.
+       #:tests? #f))))
+
 (define-public libuv-for-node
   ;; When upgrading Node, also upgrade this. Get the version from
   ;; https://github.com/nodejs/node/blob/master/deps/uv/include/uv/version.h
--8<---------------cut here---------------end--------------->8---

and using that, if it's really necessary.

Thanks,

Maxim
diff mbox series

Patch

From d6c584eeb80e3b4170d917d67a970cf640f7112c Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Sat, 4 Apr 2020 21:50:22 +0100
Subject: [PATCH 1/3] gnu: Add libuv-static.

* gnu/packages/libevent.scm (libuv-static): New variable.
---
 gnu/packages/libevent.scm | 8 ++++++++
 1 file changed, 8 insertions(+)

diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index 3754a5c427..a0534a97d5 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -178,6 +178,14 @@  and Prima).  It also comes with a very fast Pure Perl event loop that does
 not rely on XS.")
     (license perl-license)))
 
+(define-public libuv-static
+  (package/inherit libuv
+    (arguments
+      '(#:tests? #f
+        #:make-flags (list "CFLAGS=-fPIC")))
+    ;; This version is needed by zynfusion
+    (version "1.9.1")))
+
 (define-public perl-ev
   (package
     (name "perl-ev")
-- 
2.26.0