diff mbox series

[bug#48033,v2,2/2] gnu: public-inbox: Update to 1.6.1.

Message ID c4daab52ca5b3252c4bad6092c70046d3dc7f99a.1619699566.git.public@yoctocell.xyz
State Accepted
Headers show
Series [bug#48033] gnu: public-inbox: Update to 1.6.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen April 29, 2021, 12:37 p.m. UTC
* gnu/packages/mail.scm (public-inbox)[version]: Update to 1.6.1.
[inputs]: Add optional dependencies.  ‘perl-filesys-notify-simple’ has been
superseded by ‘perl-linux-inotify2’ by upstream.
[synopsis]: Capitalize “git”.
[description]: Likewise.  Mention IMAP support.
---
 gnu/packages/mail.scm | 19 +++++++++++++------
 1 file changed, 13 insertions(+), 6 deletions(-)

Comments

Kyle Meyer April 30, 2021, 11:49 p.m. UTC | #1
Xinglu Chen writes:

> diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
> index dc9c21f361..8d3d63fe37 100644
> --- a/gnu/packages/mail.scm
> +++ b/gnu/packages/mail.scm
> @@ -123,6 +123,7 @@
>    #:use-module (gnu packages perl-web)
>    #:use-module (gnu packages pkg-config)
>    #:use-module (gnu packages protobuf)
> +  #:use-module (gnu packages pretty-print)

Should this be dropped given that the `highlight' input is left as a
FIXME comment?  Otherwise this and the first patch look good to me.

Thanks.
Xinglu Chen May 1, 2021, 12:01 p.m. UTC | #2
On Fri, Apr 30 2021, Kyle Meyer wrote:

> Xinglu Chen writes:
>
>> diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
>> index dc9c21f361..8d3d63fe37 100644
>> --- a/gnu/packages/mail.scm
>> +++ b/gnu/packages/mail.scm
>> @@ -123,6 +123,7 @@
>>    #:use-module (gnu packages perl-web)
>>    #:use-module (gnu packages pkg-config)
>>    #:use-module (gnu packages protobuf)
>> +  #:use-module (gnu packages pretty-print)
>
> Should this be dropped given that the `highlight' input is left as a
> FIXME comment?  Otherwise this and the first patch look good to me.

Ah, good catch!
diff mbox series

Patch

diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index dc9c21f361..8d3d63fe37 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -123,6 +123,7 @@ 
   #:use-module (gnu packages perl-web)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages protobuf)
+  #:use-module (gnu packages pretty-print)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-check)
   #:use-module (gnu packages python-crypto)
@@ -4082,7 +4083,7 @@  Git and exports them in maildir format or to an MDA through a pipe.")
 (define-public public-inbox
   (package
     (name "public-inbox")
-    (version "1.5.0")
+    (version "1.6.1")
     (source
      (origin (method git-fetch)
              (uri (git-reference
@@ -4090,7 +4091,7 @@  Git and exports them in maildir format or to an MDA through a pipe.")
                    (commit (string-append "v" version))))
              (sha256
               (base32
-               "03zj7shdl3vibs7k5lr673bwcf8j1xx8is3mjz34ca4cdh6p5j2k"))
+               "0mlwnp5knr7rk9kv8grlh342wsq2193m22zs83cjn9p7x9r2x5f9"))
              (file-name (git-file-name name version))))
     (build-system perl-build-system)
     (arguments
@@ -4145,22 +4146,28 @@  Git and exports them in maildir format or to an MDA through a pipe.")
        ("perl-email-mime" ,perl-email-mime)
        ("perl-email-simple" ,perl-email-simple)
        ("perl-net-server" ,perl-net-server)
-       ("perl-filesys-notify-simple" ,perl-filesys-notify-simple)
        ("perl-plack-middleware-deflater" ,perl-plack-middleware-deflater)
        ("perl-plack-middleware-reverseproxy" ,perl-plack-middleware-reverseproxy)
        ("perl-plack" ,perl-plack)
        ("perl-search-xapian" ,perl-search-xapian)
        ("perl-timedate" ,perl-timedate)
        ("perl-uri-escape" ,perl-uri-escape)
+       ("perl-inline-c" ,perl-inline-c)
+       ("perl-parse-recdescent" ,perl-parse-recdescent)
+       ("perl-linux-inotify2" ,perl-linux-inotify2)
+       ;; FIXME: Perl modules are unable to find the config file for highlight
+       ;; https://issues.guix.gnu.org/48033#4
+       ;; ("highlight" ,highlight)
+
        ;; For testing.
        ("perl-ipc-run" ,perl-ipc-run)
        ("perl-xml-feed" ,perl-xml-feed)))
     (home-page "https://public-inbox.org/README.html")
-    (synopsis "Archive mailing lists in git repositories")
+    (synopsis "Archive mailing lists in Git repositories")
     (description
-     "public-inbox implements the sharing of an email inbox via git to
+     "public-inbox implements the sharing of an email inbox via Git to
 complement or replace traditional mailing lists.  Readers may read via NNTP,
-Atom feeds or HTML archives.")
+IMAP, Atom feeds or HTML archives.")
     (license license:agpl3+)))
 
 (define-public sylpheed