diff mbox series

[bug#57625,v3,2/4] gnu: Add treecc.

Message ID c4c0417c-5d11-817f-c583-a12ea8188c84@disroot.org
State New
Headers show
Series [bug#57625,v3,1/4] gnu: Add libgc-all-headers. | expand

Commit Message

Adam Faiz June 26, 2023, 1:20 p.m. UTC
From 2623ee59df8fd2c73a16deb98b455d7330e06a08 Mon Sep 17 00:00:00 2001
Message-Id: <2623ee59df8fd2c73a16deb98b455d7330e06a08.1687784497.git.adam.faiz@disroot.org>
In-Reply-To: <94149f940fc7dd3c052cfa9765933303abb7a4ee.1687784497.git.adam.faiz@disroot.org>
References: <94149f940fc7dd3c052cfa9765933303abb7a4ee.1687784497.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Fri, 18 Nov 2022 08:31:56 +0800
Subject: [PATCH v3 2/4] gnu: Add treecc.

* gnu/packages/dotgnu.scm: New file.
---
 gnu/packages/dotgnu.scm | 50 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 50 insertions(+)
 create mode 100644 gnu/packages/dotgnu.scm
diff mbox series

Patch

diff --git a/gnu/packages/dotgnu.scm b/gnu/packages/dotgnu.scm
new file mode 100644
index 0000000000..7d59496f22
--- /dev/null
+++ b/gnu/packages/dotgnu.scm
@@ -0,0 +1,50 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages dotgnu)
+  #:use-module (guix build-system gnu)
+  #:use-module (guix download)
+  #:use-module (guix gexp)
+  #:use-module (guix packages)
+  #:use-module ((guix licenses)
+                #:prefix license:)
+  #:use-module (gnu packages autotools)
+  #:use-module (gnu packages bdw-gc)
+  #:use-module (gnu packages libffi))
+
+(define-public treecc
+  (package
+    (name "treecc")
+    (version "0.3.10")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://savannah/dotgnu-pnet/"
+                    "treecc-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1rzgnspg2xccdq3qsx0vi3j28h4qkrzbrjnhzvnny34fjfk217ay"))))
+    (build-system gnu-build-system)
+    (home-page "http://www.gnu.org/software/dotgnu/")
+    (synopsis "Abstract syntax tree compiler compiler")
+    (description
+     "The treecc program is designed to assist in the development of compilers
+and other language-based tools.  It manages the generation of code to handle
+abstract syntax trees and operations upon the trees.")
+    (license license:gpl2+)))