diff mbox series

[bug#70546] gnu: cairo: Fix cross-compilation.

Message ID c496085ed765e3e8cc037c0f9fa86d79b9871bf4.1713928638.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series [bug#70546] gnu: cairo: Fix cross-compilation. | expand

Commit Message

Z572 April 24, 2024, 3:17 a.m. UTC
* gnu/packages/gtk.scm (cairo)[arguments]: When
cross-compilation, Add fix-cross-compile phase.

Change-Id: I3579bb1249c749ee5f164bb4dd47f585b181c2bc
---
 gnu/packages/gtk.scm | 16 ++++++++++++++--
 1 file changed, 14 insertions(+), 2 deletions(-)


base-commit: d115af1bcc48f07a40dafd94d1d00926d446d068

Comments

Liliana Marie Prikler April 24, 2024, 4:18 a.m. UTC | #1
Am Mittwoch, dem 24.04.2024 um 11:17 +0800 schrieb Zheng Junjie:
> * gnu/packages/gtk.scm (cairo)[arguments]: When
> cross-compilation, Add fix-cross-compile phase.
> 
> Change-Id: I3579bb1249c749ee5f164bb4dd47f585b181c2bc
> ---
Haven't checked that it works yet, but at least lexically it LGTM.
For the commit message – particularly the ChangeLog portion – I'd say
"Add ‘fix-cross-compilation’ phase when cross-compiling." and adjust
the phase name accordingly.

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index b0098e780e..8fcd3ed1f3 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -34,7 +34,7 @@ 
 ;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
 ;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
 ;;; Copyright © 2023 Sergiu Ivanov <sivanov@colimite.fr>
-;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2023, 2024 Zheng Junjie <873216071@qq.com>
 ;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
 ;;; Copyright © 2024 John Kehayias <john.kehayias@protonmail.com>
 ;;;
@@ -182,7 +182,19 @@  (define cairo
      `(#:tests? #f ; see http://lists.gnu.org/archive/html/bug-guix/2013-06/msg00085.html
        #:glib-or-gtk? #t
        #:configure-flags
-       (list "-Dtests=disabled")))
+       (list "-Dtests=disabled")
+       ,@(if (%current-target-system)
+             `(#:phases
+               (modify-phases %standard-phases
+                 (add-after 'unpack 'fix-cross-compile
+                   (lambda _
+                     ;; XXX: Let meson-build-system can customize the property
+                     (substitute* "meson.build"
+                       (("'ipc_rmid_deferred_release', 'auto'")
+                        ;; see https://github.com/NixOS/nixpkgs/blob/df51f2293e935e85f6a2e69bcf89a40cb31bbc3d/pkgs/development/libraries/cairo/default.nix#L65
+                        ;; XXX: check it on hurd.
+                        "'ipc_rmid_deferred_release', 'true'"))))))
+             '())))
     (native-inputs
      `(,@(if (target-hurd?)
              '()