diff mbox series

[bug#54165,v2,1/2] gnu: guile-bytestructures: Update to 2.0.1.

Message ID c48b47ba696a8068fda077c9a8e2a167bc21c677.1717767896.git.felix.lechner@lease-up.com
State New
Headers show
Series [bug#54165,v2,1/2] gnu: guile-bytestructures: Update to 2.0.1. | expand

Commit Message

Felix Lechner June 7, 2024, 1:44 p.m. UTC
From: Taylan Kammer <taylan.kammer@gmail.com>

* gnu/packages/guile.scm (guile-bytestructures): Update to 2.0.1.

Although the major version number is increased due to a small API-breaking
change, all packages that depend on guile-bytestructures still build fine and
pass their test suite if they have one, so it should not be necessary to
create a bytestructures-2.0 package.

The breaking change is that bs:pointer would previously implicitly dereference
the pointer when any index other than '* was provided, whereas in this version
the dereference must be explicit, and can be '* or an integer that represents
an offset from the pointer address a la *(ptr + i) in C.
---
 gnu/packages/guile.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)


base-commit: 580d77d0fb12448ef1621699cc0c56e787e2aadb
diff mbox series

Patch

diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index e8705dc7d2..0bbd4a12ad 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -786,7 +786,7 @@  (define-public guile2.2-sqlite3
 (define-public guile-bytestructures
   (package
     (name "guile-bytestructures")
-    (version "1.0.10")
+    (version "2.0.1")
     (home-page "https://github.com/TaylanUB/scheme-bytestructures")
     (source (origin
               (method git-fetch)
@@ -796,7 +796,7 @@  (define-public guile-bytestructures
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "14k50jln32kkxv41hvsdgjkkfj6xlv06vc1caz01qkgk1fzh72nk"))))
+                "1gnh3p2042cch1nkapl0p4pv20q7qs8cxvvbp7a5h1dwqbrkdyss"))))
     (build-system gnu-build-system)
     (arguments
      `(#:make-flags '("GUILE_AUTO_COMPILE=0")     ;to prevent guild warnings