diff mbox series

[bug#67119,4/4] gnu: ovmf: Update ovmf-arm with GCC5.

Message ID c4637fa2f6256a0bdbdc37b0a4fb2b4d@purge.sh
State New
Headers show
Series [bug#67119,1/4] gnu: ovmf: Update to 202308. | expand

Commit Message

spacecadet Nov. 12, 2023, 3:07 a.m. UTC
Updating OVMF to 202308 requires GCC5, packages inheriting from ovmf
also need to be updated.
---
  gnu/packages/firmware.scm | 61 ++++++++++++++++++++-------------------
  1 file changed, 31 insertions(+), 30 deletions(-)

+                    (mkdir-p fmw)
+                    (copy-file (string-append 
"Build/ArmVirtQemu-ARM/RELEASE_" #$toolchain-ver "/FV/QEMU_EFI.fd")
+                               (string-append fmw 
"/ovmf_arm.bin")))))))))
+      (supported-systems %supported-systems))))

  (define* (make-arm-trusted-firmware platform
                                      #:key (triplet 
"aarch64-linux-gnu"))
diff mbox series

Patch

diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index e713aa9ac6..0ee618cbcb 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -1014,36 +1014,37 @@  (define-public ovmf-aarch64
        (supported-systems %supported-systems))))

  (define-public ovmf-arm
-  (package
-    (inherit ovmf)
-    (name "ovmf-arm")
-    (native-inputs
-     (append (package-native-inputs ovmf)
-             (if (not (string-prefix? "armhf" (%current-system)))
-                 `(("cross-gcc" ,(cross-gcc "arm-linux-gnueabihf"))
-                   ("cross-binutils" ,(cross-binutils 
"arm-linux-gnueabihf")))
-                 '())))
-    (arguments
-     (substitute-keyword-arguments (package-arguments ovmf)
-       ((#:phases phases)
-        #~(modify-phases #$phases
-            #$@(if (string-prefix? "armhf" (%current-system))
-                   '()
-                   '((add-before 'configure 'set-env
-                       (lambda _
-                         (setenv "GCC49_ARM_PREFIX" 
"arm-linux-gnueabihf-")))))
-            (replace 'build
-              (lambda _
-                (invoke "build" "-a" "ARM" "-t" "GCC49"
-                        "-p" "ArmVirtPkg/ArmVirtQemu.dsc")))
-            (delete 'build-x64)
-            (replace 'install
-              (lambda _
-                (let ((fmw (string-append #$output "/share/firmware")))
-                  (mkdir-p fmw)
-                  (copy-file 
"Build/ArmVirtQemu-ARM/RELEASE_GCC49/FV/QEMU_EFI.fd"
-                             (string-append fmw 
"/ovmf_arm.bin")))))))))
-    (supported-systems %supported-systems)))
+  (let ((toolchain-ver "GCC5"))
+    (package
+      (inherit ovmf)
+      (name "ovmf-arm")
+      (native-inputs
+       (append (package-native-inputs ovmf)
+               (if (not (string-prefix? "armhf" (%current-system)))
+                   `(("cross-gcc" ,(cross-gcc "arm-linux-gnueabihf"))
+                     ("cross-binutils" ,(cross-binutils 
"arm-linux-gnueabihf")))
+                   '())))
+      (arguments
+       (substitute-keyword-arguments (package-arguments ovmf)
+         ((#:phases phases)
+          #~(modify-phases #$phases
+              #$@(if (string-prefix? "armhf" (%current-system))
+                     '()
+                     #~((add-before 'configure 'set-env
+                          (lambda _
+                            (setenv (string-append #$toolchain-ver 
"_ARM_PREFIX") "arm-linux-gnueabihf-")))))
+              (replace 'build
+                (lambda _
+                  (invoke "build" "-a" "ARM" "-t" #$toolchain-ver
+                          "-p" "ArmVirtPkg/ArmVirtQemu.dsc")))
+              (delete 'build-x64)
+              (replace 'install
+                (lambda _
+                  (let ((fmw (string-append #$output 
"/share/firmware")))