diff mbox series

[bug#68932] gnu: Add r-rpresto.

Message ID c43fc214bf734eb3014eca4c8d3ac4e3ed40443a.1707127447.git.navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#68932] gnu: Add r-rpresto. | expand

Commit Message

nafkhamdc Feb. 5, 2024, 10:04 a.m. UTC
* gnu/packages/cran.scm (r-rpresto): New variable.

Change-Id: I81b0e43ca75ab2df36f67367bfc73c4893be1a30
---
 gnu/packages/cran.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)


base-commit: 5a806face508cdfcd91e1eb1afb3ec38c002ec92

Comments

Sharlatan Hellseher Feb. 24, 2024, 9:58 a.m. UTC | #1
Hi,

CC'd Ricardo to check license acceptance.

I've checked the package for lint/build, add copyright header, slightly
adjust description and re-indent propagated inputs. When I've been
checking license on CRAN and project's VCS page I noticed this
statement:

https://cran.r-project.org/web/packages/RPresto/index.html
--8<---------------cut here---------------start------------->8---
License:        BSD_3_clause + file LICENSE
Copyright:      Meta Platforms, Inc. 2015-present.
--8<---------------cut here---------------end--------------->8---

https://github.com/prestodb/RPresto/blob/master/LICENSE
--8<---------------cut here---------------start------------->8---
YEAR: 2015-present
COPYRIGHT HOLDER: Meta Platforms, Inc. and affiliates. All rights reserved.
ORGANIZATION: Meta Platforms, Inc. and affiliates
--8<---------------cut here---------------end--------------->8---

Sending v2 of the patch with minor modifications.

nafkhamdc (1):
  gnu: Add r-rpresto.

 gnu/packages/cran.scm | 39 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)


base-commit: c0f88cd18649c31c75bcddf8247b14ef3e3a66a5
--
2.41.0
Ricardo Wurmus Feb. 25, 2024, 9:26 a.m. UTC | #2
Thanks for the review.  I applied it.
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 842946e766..fecf77580c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1411,6 +1411,43 @@  (define-public r-pma
 canonical correlation analysis.")
     (license license:gpl2+)))
 
+(define-public r-rpresto
+  (package
+    (name "r-rpresto")
+    (version "1.4.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "RPresto" version))
+       (sha256
+        (base32 "1q8c3h328iwscnayxj8qc71s2hkqdqwnpf38kn3zz3ks66qzjf8c"))))
+    (properties `((upstream-name . "RPresto")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-bit64
+                             r-dbi
+                             r-dbplyr
+                             r-dplyr
+                             r-httr
+                             r-jsonlite
+                             r-lifecycle
+                             r-lubridate
+                             r-openssl
+                             r-progress
+                             r-purrr
+                             r-rlang
+                             r-stringi
+                             r-tibble
+                             r-vctrs))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/prestodb/RPresto")
+    (synopsis "DBI connector to Presto")
+    (description
+     "This package implements a DBI compliant interface to Presto.
+Presto is an open source distributed SQL query engine for running
+interactive analytic queries against data sources of all sizes
+ranging from gigabytes to petabytes.")
+    (license license:bsd-3)))
+
 (define-public r-prettydoc
   (package
     (name "r-prettydoc")