diff mbox series

[bug#38095] gnu: Add matcha-theme.

Message ID c43c1cccc58284c7195a078997900c44f061fbae.camel@student.tugraz.at
State Accepted
Headers show
Series [bug#38095] gnu: Add matcha-theme. | expand

Commit Message

Leo Prikler Nov. 9, 2019, 10:03 a.m. UTC
I've taken the liberty to modify your package a bit -- your unquotes
were wrong -- and move it to gnome-xyz.scm, the file I've added for
themes and extensions.  I verified, that the package builds and also
ran the linter.  The only errors are some versioning stuff (a false
positive) and a missing Software Heritage archive (which was to be
expected).

I noticed, that there are also some other themes inside of gnome.scm,
since my own file is rather fresh.  If the contributors of said
packages are reading this, I'd like them to also move their themes and
extensions to gnome-xyz.scm -- except adwaita-icon-theme, gnome-shell-
extensions, etc. which are part of GNOME itself. 

Thank you and best regards,

Leo

Comments

Ludovic Courtès Nov. 9, 2019, 9:47 p.m. UTC | #1
Hi Leo and Alexandros,

I changed the license to ‘gpl3+’ (was ‘gpl3’) because the package does
not mandate any specific version, and applied the patch.

Thanks to both of you for your work!

Ludo’.
diff mbox series

Patch

From 1ecf8bb9c4d1a47c2f7ca936725d2ceb74a379c4 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Sat, 9 Nov 2019 10:39:28 +0100
Subject: [PATCH] gnu: Add matcha-theme.

* gnu/packages/gnome.scm (matcha-theme): New variable.
---
 gnu/packages/gnome-xyz.scm | 50 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 50 insertions(+)

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 8c45b552e8..1365c1b9cf 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -1,5 +1,6 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2019 Leo Prikler <leo.prikler@student.tugraz.at>
+;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -23,9 +24,58 @@ 
   #:use-module (guix packages)
   #:use-module ((guix licenses) #:prefix license:)
 
+  #:use-module (gnu packages base)
+  #:use-module (gnu packages bash)
   #:use-module (gnu packages glib)
+  #:use-module (gnu packages gtk)
   #:use-module (gnu packages pkg-config))
 
+(define-public matcha-theme
+  (package
+    (name "matcha-theme")
+    (version "2019-11-02")
+    (source
+      (origin
+        (method git-fetch)
+        (uri
+          (git-reference
+            (url "https://github.com/vinceliuice/matcha")
+            (commit version)))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32
+            "0wci9ahap8kynq8cbyxr7aba9ndb1d4kiq42xvzr34vw1rhcahrr"))))
+    (build-system trivial-build-system)
+    (arguments
+     '(#:modules ((guix build utils))
+       #:builder
+       (begin
+         (use-modules (guix build utils))
+         (let* ((out (assoc-ref %outputs "out"))
+                (source (assoc-ref %build-inputs "source"))
+                (bash (assoc-ref %build-inputs "bash"))
+                (coreutils (assoc-ref %build-inputs  "coreutils"))
+                (themesdir (string-append out "/share/themes")))
+           (setenv "PATH"
+                   (string-append coreutils "/bin:"
+                                  (string-append bash "/bin:")))
+           (copy-recursively source (getcwd))
+           (patch-shebang "Install")
+           (mkdir-p themesdir)
+           (invoke "./Install" "-d" themesdir)
+           #t))))
+    (inputs
+     `(("gtk-engines" ,gtk-engines)))
+    (native-inputs
+     `(("bash" ,bash)
+       ("coreutils" ,coreutils)))
+    (synopsis "Flat design theme for GTK 3, GTK 2 and GNOME-Shell")
+    (description "Matcha is a flat Design theme for GTK 3, GTK 2 and
+Gnome-Shell which supports GTK 3 and GTK 2 based desktop environments
+like Gnome, Unity, Budgie, Pantheon, XFCE, Mate and others.")
+    (home-page "https://github.com/vinceliuice/matcha")
+    (license license:gpl3)))
+
 (define-public delft-icon-theme
   (package
     (name "delft-icon-theme")
-- 
2.24.0