[bug#76960,sysadmin-team,v3,3/3] gnu: kddockwidgets: Update to 2.2.1.

Message ID c43a55805e995dbff4777c23bd12d80f6d4aac98.1742490675.git.code@greghogan.com
State New
Headers
Series Update spdlog. |

Commit Message

Greg Hogan March 20, 2025, 5:18 p.m. UTC
  * gnu/packages/qt.scm (kddockwidgets): Update to 2.2.1.

Change-Id: I10f7a542ad6d234b1123fc1dbdc6b19781f54d1b
---
 gnu/packages/qt.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
  

Comments

Maxim Cournoyer March 21, 2025, 1:18 p.m. UTC | #1
Hi Greg,

Greg Hogan <code@greghogan.com> writes:

> * gnu/packages/qt.scm (kddockwidgets): Update to 2.2.1.

This series LGTM, but I'd push this update first, and squash the two
other spdlog commits together, so that the impacted packages build fine
on all commits.

Feel free to push after reworking the commits that way.
  
Greg Hogan March 21, 2025, 2:36 p.m. UTC | #2
On Fri, Mar 21, 2025 at 9:18 AM Maxim Cournoyer
<maxim.cournoyer@gmail.com> wrote:
>
> Hi Greg,
>
> Greg Hogan <code@greghogan.com> writes:
>
> > * gnu/packages/qt.scm (kddockwidgets): Update to 2.2.1.
>
> This series LGTM, but I'd push this update first, and squash the two
> other spdlog commits together, so that the impacted packages build fine
> on all commits.
>
> Feel free to push after reworking the commits that way.
>
> --
> Thanks,
> Maxim

I will do this because I defer to your experience and expertise, and
also I do not particularly care about this pair of patches, but no one
will have tested the updated kddockwidgets against the old version of
spdlog (albeit this is much better than the known breakage in the
other order). I just do not see this preference being generally
applied elsewhere. We struggle to keep Guix mostly buildable, much
less after every commit. We should make releases rather than squashed
commits as points of stability.
  
Maxim Cournoyer March 22, 2025, 10:35 a.m. UTC | #3
Hi Greg,

Greg Hogan <code@greghogan.com> writes:

> On Fri, Mar 21, 2025 at 9:18 AM Maxim Cournoyer
> <maxim.cournoyer@gmail.com> wrote:
>>
>> Hi Greg,
>>
>> Greg Hogan <code@greghogan.com> writes:
>>
>> > * gnu/packages/qt.scm (kddockwidgets): Update to 2.2.1.
>>
>> This series LGTM, but I'd push this update first, and squash the two
>> other spdlog commits together, so that the impacted packages build fine
>> on all commits.
>>
>> Feel free to push after reworking the commits that way.
>>
>> --
>> Thanks,
>> Maxim
>
> I will do this because I defer to your experience and expertise, and
> also I do not particularly care about this pair of patches, but no one
> will have tested the updated kddockwidgets against the old version of
> spdlog (albeit this is much better than the known breakage in the
> other order). I just do not see this preference being generally
> applied elsewhere.

Thanks.  I think it became a bit more of a concern post 'guix
time-machine'.

> We struggle to keep Guix mostly buildable, much
> less after every commit. We should make releases rather than squashed
> commits as points of stability.

I somewhat disagree on this; releases will typically invest efforts in
testing the release artifacts such as graphical installer, the
installation script, the sample VM image, etc. but won't/can't be a
guarantee that the complete package collections has been QA'd.

So it's still very valuable and needed to have good self-QA hygiene on
our own individual commits.  Package test suites go a long way to
provide some guarantee that it should work; system tests can be another
one, or simply validating a binary runs correctly.
  

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 13893d2951..94cc879f4a 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -313,7 +313,7 @@  (define-public qt6ct
 (define-public kddockwidgets
   (package
     (name "kddockwidgets")
-    (version "2.1.0")
+    (version "2.2.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -322,7 +322,7 @@  (define-public kddockwidgets
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0s4s0y8kvkyf15d5kzcd5wik7n1jj9mxrmc60irlacfy93hmdaw0"))))
+                "0d0pxynlyfgavf6l1b1z7zpmbrzm96hkphnqnalr7mshm147450g"))))
     (build-system cmake-build-system)
     (arguments (list #:configure-flags #~(list
                                           "-DKDDockWidgets_QT6=ON"