diff mbox series

[bug#54137] gnu: OpenSSH: Update to 8.9p1.

Message ID c41ebd759970bd194c667ac39f63c5865a7b69cf.1645683939.git.leo@famulari.name
State Accepted
Headers show
Series [bug#54137] gnu: OpenSSH: Update to 8.9p1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Leo Famulari Feb. 24, 2022, 6:25 a.m. UTC
* gnu/packages/ssh.scm (openssh): Update to 8.9p1.
---
 gnu/packages/ssh.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Maxim Cournoyer Feb. 26, 2022, 5:29 a.m. UTC | #1
Hi Leo,

Leo Famulari <leo@famulari.name> writes:

> * gnu/packages/ssh.scm (openssh): Update to 8.9p1.
> ---
>  gnu/packages/ssh.scm | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
> index 8e29968ea7..7c8b09879f 100644
> --- a/gnu/packages/ssh.scm
> +++ b/gnu/packages/ssh.scm
> @@ -184,7 +184,7 @@ (define-public libssh2
>  (define-public openssh
>    (package
>     (name "openssh")
> -   (version "8.8p1")
> +   (version "8.9p1")
>     (source (origin
>               (method url-fetch)
>               (uri (string-append "mirror://openbsd/OpenSSH/portable/"
> @@ -192,7 +192,7 @@ (define-public openssh
>               (patches (search-patches "openssh-hurd.patch"))
>               (sha256
>                (base32
> -               "1s8z6f7mi1pwsl79cqai8cr350m5lf2ifcxff57wx6mvm478k425"))))
> +               "1ry5prcax0134v6srkgznpl9ch5snkgq7yvjqvd8c5mbnxa7cjgx"))))
>     (build-system gnu-build-system)
>     (native-inputs (list groff pkg-config))
>     (inputs `(("libedit" ,libedit)

Haven't tried it, but I read the changelog and it LGTM.

Maxim
Leo Famulari Feb. 27, 2022, 11 p.m. UTC | #2
On Sat, Feb 26, 2022 at 12:29:22AM -0500, Maxim Cournoyer wrote:
> Haven't tried it, but I read the changelog and it LGTM.

It's working for me, so I pushed as
9b0171fe1ae499f57462c4b45e91ef68e076f57d
diff mbox series

Patch

diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 8e29968ea7..7c8b09879f 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -184,7 +184,7 @@  (define-public libssh2
 (define-public openssh
   (package
    (name "openssh")
-   (version "8.8p1")
+   (version "8.9p1")
    (source (origin
              (method url-fetch)
              (uri (string-append "mirror://openbsd/OpenSSH/portable/"
@@ -192,7 +192,7 @@  (define-public openssh
              (patches (search-patches "openssh-hurd.patch"))
              (sha256
               (base32
-               "1s8z6f7mi1pwsl79cqai8cr350m5lf2ifcxff57wx6mvm478k425"))))
+               "1ry5prcax0134v6srkgznpl9ch5snkgq7yvjqvd8c5mbnxa7cjgx"))))
    (build-system gnu-build-system)
    (native-inputs (list groff pkg-config))
    (inputs `(("libedit" ,libedit)