From 0f5664eac9dd7e4b159fa35d415986261c6913fe Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Fri, 3 Jan 2020 11:22:37 -0500
Subject: [PATCH] gnu: Add gupnp-av.
* gnu/packages/gnome.scm (gupnp-av): New variable.
---
gnu/packages/gnome.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)
@@ -306,6 +306,35 @@ UPnP devices and control points, written in C using GObject and libsoup.")
(home-page "https://gitlab.gnome.org/GNOME/gupnp")
(license license:gpl2)))
+(define-public gupnp-av
+ (package
+ (name "gupnp-av")
+ (version "0.12.11")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1p3grslwqm9bc8rmpn4l48d7v9s84nina4r9xbd932dbj8acz7b8"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gtk-doc" ,gtk-doc)
+ ("gobject-introspection" ,gobject-introspection)
+ ("gtk+" ,gtk+)
+ ("gupnp" ,gupnp)
+ ("libxml" ,libxml2)))
+ (synopsis "GUPnP A/V for GNOME desktop")
+ (description "GUPnP A/V is a small utility library that aims to ease
+the handling and implementation of UPnP A/V profiles.")
+ (home-page "https://gitlab.gnome.org/GNOME/gupnp-av")
+ (license license:gpl2)))
+
(define-public libmediaart
(package
(name "libmediaart")
--
2.24.1