diff mbox series

[bug#63527,v5,02/11] gnu: hurd: Update libpciaccess to 0.17.

Message ID c40c3fcbe5b59de0a64dbbd781e7b4458146f334.1684855847.git.janneke@gnu.org
State New
Headers show
Series [bug#63527,v5,01/11] gnu: Add libpciaccess-0.17. | expand

Commit Message

Janneke Nieuwenhuizen May 23, 2023, 3:47 p.m. UTC
As suggested by youpi on IRC

    https://logs.guix.gnu.org/hurd/2023-05-17.log#132259

libpciaccess-0.16 is too old for the Hurd and would need Hurd-specific patches
while libpciaccess-0.17 works out of the box.

* gnu/packages/hurd.scm (hurd)[inputs]: Use libpciaccess-0.17.
(netdde)[inputs]: Likewise.
---
 gnu/packages/hurd.scm | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

Comments

Ludovic Courtès May 24, 2023, 9:11 a.m. UTC | #1
Janneke Nieuwenhuizen <janneke@gnu.org> skribis:

> As suggested by youpi on IRC
>
>     https://logs.guix.gnu.org/hurd/2023-05-17.log#132259
>
> libpciaccess-0.16 is too old for the Hurd and would need Hurd-specific patches
> while libpciaccess-0.17 works out of the box.
>
> * gnu/packages/hurd.scm (hurd)[inputs]: Use libpciaccess-0.17.
> (netdde)[inputs]: Likewise.

[…]

> +       ("libpciaccess" ,libpciaccess-0.17)

Maybe add “;need libpciaccess > 0.16” to convey that we should be able
to safely upgrade next time.

Ludo’.
Janneke Nieuwenhuizen May 24, 2023, 9:28 a.m. UTC | #2
Ludovic Courtès writes:

> Janneke Nieuwenhuizen <janneke@gnu.org> skribis:
>
>> As suggested by youpi on IRC
>>
>>     https://logs.guix.gnu.org/hurd/2023-05-17.log#132259
>>
>> libpciaccess-0.16 is too old for the Hurd and would need Hurd-specific patches
>> while libpciaccess-0.17 works out of the box.
>>
>> * gnu/packages/hurd.scm (hurd)[inputs]: Use libpciaccess-0.17.
>> (netdde)[inputs]: Likewise.
>
> […]
>
>> +       ("libpciaccess" ,libpciaccess-0.17)
>
> Maybe add “;need libpciaccess > 0.16” to convey that we should be able
> to safely upgrade next time.

Nice, yes that's helpful.  Done.

Greetings,
Janneke
diff mbox series

Patch

diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index a0133482b7..d8b4dcaf4f 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -3,7 +3,7 @@ 
 ;;; Copyright © 2018, 2020-2023 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2020, 2022 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2020, 2022, 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
 ;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2020 Rene Saavedra <pacoon@protonmail.com>
 ;;;
@@ -45,7 +45,7 @@  (define-module (gnu packages hurd)
   #:use-module (gnu packages bash)
   #:use-module (gnu packages texinfo)
   #:use-module (gnu packages onc-rpc)
-  #:use-module (gnu packages xorg) ; libpciaccess
+  #:use-module (gnu packages xorg) ;libpciaccess-0.17
   #:use-module (guix git-download)
   #:export (hurd-system?
             hurd-target?))
@@ -536,7 +536,7 @@  (define-public hurd
      `(("libgcrypt" ,libgcrypt)                  ;for /hurd/random
        ("libdaemon" ,libdaemon)                  ;for /bin/console --daemonize
        ("unifont" ,unifont)
-       ("libpciaccess" ,libpciaccess)
+       ("libpciaccess" ,libpciaccess-0.17)
 
        ;; For NFS support
        ("libtirpc" ,libtirpc/hurd)
@@ -634,7 +634,7 @@  (define-public netdde
                                             "/bin"))
                #t)))))
       (inputs
-       (list hurd libpciaccess zlib))
+       (list hurd libpciaccess-0.17 zlib))
       (native-inputs
        `(("coreutils" ,coreutils)
          ("gawk" ,gawk)