diff mbox series

[bug#73299,v2,2/3] gnu: go-github-com-prometheus-statsd-exporter: Remove redundant phase.

Message ID c4069e80755c59a57a47c6069d0f15d176cb4644.1726516329.git.sharlatanus@gmail.com
State New
Headers show
Series [bug#73299,v2,1/3] build/go: Replace symlinks with a copy of the file. | expand

Commit Message

Sharlatan Hellseher Sept. 16, 2024, 8:10 p.m. UTC
* gnu/packages/prometheus.scm (go-github-com-prometheus-statsd-exporter)
[arguments]: <#:phases>: Remove 'fix-embed-files and relay on standard
one.

Change-Id: I1bc965c65bcd40fcaef7d0ace9943a01ef08bdd3
---
 gnu/packages/prometheus.scm | 24 +-----------------------
 1 file changed, 1 insertion(+), 23 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/prometheus.scm b/gnu/packages/prometheus.scm
index fe2fa18e95..a81932f62b 100644
--- a/gnu/packages/prometheus.scm
+++ b/gnu/packages/prometheus.scm
@@ -572,29 +572,7 @@  (define-public go-github-com-prometheus-statsd-exporter
     (arguments
      (list
       #:import-path "github.com/prometheus/statsd_exporter"
-      #:phases
-      #~(modify-phases %standard-phases
-          ;; TODO: Implement it in go-build-system.
-          ;;
-          ;; This happens due to Golang can't determine the valid directory of
-          ;; the module of embed file which is symlinked during setup
-          ;; environment phase, but easy resolved after coping file from the
-          ;; store to the build directory of the current package, see details
-          ;; in Golang source:
-          ;;
-          ;; - URL: <https://github.com/golang/go/blob/>
-          ;; - commit: 82c14346d89ec0eeca114f9ca0e88516b2cda454
-          ;; - file: src/cmd/go/internal/load/pkg.go#L2059
-          (add-before 'build 'fix-embed-files
-            (lambda _
-              (for-each (lambda (file)
-                          (let ((file-store-path (readlink file)))
-                            (delete-file file)
-                            (copy-recursively file-store-path file)))
-                        (find-files "src" (string-append
-                                           ".*(editions_defaults.binpb"
-                                           "|landing_page.css"
-                                           "|landing_page.html)$"))))))))
+      #:embed-files #~(list "landing_page.css" "landing_page.html")))
     (native-inputs
      (list go-github-com-stvp-go-udp-testing))
     (propagated-inputs