diff mbox series

[bug#67120,v6,2/5] gnu: Add python-jellyfin-apiclient.

Message ID c40171e6981e706bce7d979fae1ad5522609a38f.1708899540.git.ian@retrospec.tv
State New
Headers show
Series Add jellyfin-mpv-player and deps | expand

Commit Message

Ian Eure Feb. 25, 2024, 10:20 p.m. UTC
* gnu/packages/python-xyz.scm (python-jellyfin-apiclient): New variable.

Change-Id: If84546b14d380a3a10af63d4f41711125298487a
---
 gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b6001416a6..1ed1f0e135 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25825,6 +25825,26 @@  (define-public python-mpv-jsonipc
 python-mpv, but it uses the JSON IPC protocol instead of the C API.")
     (license license:asl2.0)))
 
+(define-public python-jellyfin-apiclient
+  (package
+    (name "python-jellyfin-apiclient")
+    (version "1.9.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "jellyfin-apiclient-python" version))
+       (sha256
+        (base32 "0r67cp9nizvn3cbslgi30zpd3mw4a6zal0ygik3jv5lni1xdkk5w"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-certifi python-requests python-urllib3
+                             python-websocket-client))
+    (home-page "https://github.com/jellyfin/jellyfin-apiclient-python")
+    (synopsis "Python API client for Jellyfin")
+    (description "python-jellyfin-apiclient allows use of the Jellyfin API
+from Python.  It was extracted from the Jellyfin Kodi plugin so other users
+may use the Jellyfin API more easily.")
+    (license license:gpl3)))
+
 (define-public python-parso
   (package
     (name "python-parso")