diff mbox series

[bug#42276,1/2] gnu: carla: Update to 2.1.1.

Message ID c3f98495696e0009b3d1177d7848840f3abaf705.camel@zrythm.org
State Accepted
Headers show
Series [bug#42276,1/2] gnu: carla: Update to 2.1.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou July 8, 2020, 8:34 p.m. UTC
Hi,

These patches update carla and add gtk2 as a dependency, so it can be
used to bridge gtk2 plugins inside gtk3/qt5 hosts.

Thanks,
Alex

Comments

Marius Bakke July 20, 2020, 9:51 p.m. UTC | #1
Alexandros Theodotou <alex@zrythm.org> writes:

> Hi,
>
> These patches update carla and add gtk2 as a dependency, so it can be
> used to bridge gtk2 plugins inside gtk3/qt5 hosts.

[...]

> diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
> index cf80113520..91013547cf 100644
> --- a/gnu/packages/audio.scm
> +++ b/gnu/packages/audio.scm
> @@ -4077,6 +4077,8 @@ as is the case with audio plugins.")
>         ("file" ,file)
>         ("liblo" ,liblo)
>         ("libsndfile" ,libsndfile)
> +       ;; needed for bridging Gtk2 plugins in Gtk3 hosts
> +       ("gtk2" ,gtk+-2)

I moved the comment to the same line and applied both patches.

(the alternative was to turn it into a full sentence with capitalization
and punctuation as we usually do for non-margin comments)
diff mbox series

Patch

From ec79b9bc3795638e446d244719e6112e134ab56f Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Wed, 8 Jul 2020 21:30:39 +0100
Subject: [PATCH 1/2] gnu: carla: Update to 2.1.1.

* gnu/packages/audio.scm (carla): Update to 2.1.1.
---
 gnu/packages/audio.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 47cec4fea2..cf80113520 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -4035,7 +4035,7 @@  as is the case with audio plugins.")
 (define-public carla
   (package
     (name "carla")
-    (version "2.0.0")
+    (version "2.1.1")
     (source
      (origin
        (method git-fetch)
@@ -4046,7 +4046,7 @@  as is the case with audio plugins.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0fqgncqlr86n38yy7pa118mswfacmfczj7w9xx6c6k0jav3wk29k"))))
+         "0c3y4a6cgi4bv1mg57i3qn5ia6pqjqlaylvkapj6bmpsw71ig22g"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f                      ; no "check" target
-- 
2.27.0