diff mbox series

[bug#51585] gnu: Add emacs-flymake-flycheck.

Message ID c3e95e7f-5a29-b748-b5ae-64f9781f10cf@tom-fitzhenry.me.uk
State Accepted
Headers show
Series [bug#51585] gnu: Add emacs-flymake-flycheck. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Tom Fitzhenry Nov. 3, 2021, 2:02 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-flymake-flycheck): New variable.
---
  gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
  1 file changed, 23 insertions(+)

    (let ((version "1.0.0")

Comments

Ludovic Courtès Nov. 12, 2021, 10:51 p.m. UTC | #1
Hi,

Tom Fitzhenry <tom@tom-fitzhenry.me.uk> skribis:

> * gnu/packages/emacs-xyz.scm (emacs-flymake-flycheck): New variable.

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 543ce6303a..8253d7d562 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1586,6 +1586,29 @@  (define-public emacs-flycheck
  provides an optional IDE-like error list.")
        (license license:gpl3+))))                     ;+GFDLv1.3+ for 
the manual

+(define-public emacs-flymake-flycheck
+  (package
+    (name "emacs-flymake-flycheck")
+    (version "20210404.2128")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://melpa.org/packages/flymake-flycheck-"
+             version
+             ".el"))
+       (sha256
+        (base32 "1m59ahd5gjlfwf328labwdlpcxh8ywywkwgfrlsy5jyxfc9ss4nv"))))
+    (build-system emacs-build-system)
+    (propagated-inputs `(("emacs-flycheck" ,emacs-flycheck)))
+    (home-page "https://github.com/purcell/flymake-flycheck")
+    (synopsis "Use flycheck checkers as flymake backends")
+    (description
+     "This package provides support for running any flycheck checker as a
+flymake diagnostic backend.  The effect is that flymake will
+control when the checker runs, and flymake will receive its errors.")
+    (license license:gpl3)))
+
  (define-public emacs-flymake-quickdef
    ;; This particular commit includes bug fixes on top of 1.0.0 release.