diff mbox series

[bug#61518] gnu: Remove psi.

Message ID c3da4ef067d2a174ef4f690691ec7a8d20bae324.1676411565.git.leo@famulari.name
State New
Headers show
Series [bug#61518] gnu: Remove psi. | expand

Commit Message

Leo Famulari Feb. 14, 2023, 9:52 p.m. UTC
This package requires QtWebKit, which is being removed from Guix.

See <https://issues.guix.gnu.org/53289> for more information.

* gnu/packages/messaging.scm (psi): Remove variable.
---
 gnu/packages/messaging.scm | 56 --------------------------------------
 1 file changed, 56 deletions(-)

Comments

Jack Hill Feb. 14, 2023, 10:07 p.m. UTC | #1
On Tue, 14 Feb 2023, Leo Famulari wrote:

> This package requires QtWebKit, which is being removed from Guix.
>
> See <https://issues.guix.gnu.org/53289> for more information.
>
> * gnu/packages/messaging.scm (psi): Remove variable.

Should we deprecate it in favor of psi-plus?

Best,
Jack
Leo Famulari Feb. 14, 2023, 10:19 p.m. UTC | #2
On Tue, Feb 14, 2023 at 05:07:58PM -0500, Jack Hill wrote:
> On Tue, 14 Feb 2023, Leo Famulari wrote:
> 
> > This package requires QtWebKit, which is being removed from Guix.
> > 
> > See <https://issues.guix.gnu.org/53289> for more information.
> > 
> > * gnu/packages/messaging.scm (psi): Remove variable.
> 
> Should we deprecate it in favor of psi-plus?

That's a good idea, thanks! Are you able to write a patch? :)
Leo Famulari Feb. 17, 2023, 7:52 p.m. UTC | #3
Pushed as 7eb3eec4dacc414a6680a97bc6ef38c1f76b947e
diff mbox series

Patch

diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 3027d56907..231ee1c5d3 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -193,62 +193,6 @@  (define-public omemo-wget
 XMPP-based sessions.")
     (license license:lgpl3+)))
 
-(define-public psi
-  (package
-    (name "psi")
-    (version "1.5")
-    (source
-     (origin
-       (method url-fetch)
-       (uri
-        (string-append "mirror://sourceforge/psi/Psi/"
-                       version "/psi-" version ".tar.xz"))
-       (modules '((guix build utils)))
-       (snippet
-        `(begin
-           (delete-file-recursively "3rdparty")))
-       (sha256
-        (base32 "1dxmm1d1zr0pfs51lba732ipm6hm2357jlfb934lvarzsh7karri"))))
-    (build-system qt-build-system)
-    (arguments
-     `(#:tests? #f                      ; No target
-       #:configure-flags
-       (list
-        "-DUSE_ENCHANT=ON"
-        "-DUSE_CCACHE=OFF")
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch-cmake
-           (lambda _
-             (substitute* "cmake/modules/FindHunspell.cmake"
-               (("hunspell-1.6")
-                "hunspell-1.7"))
-             #t)))))
-    (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("python" ,python-wrapper)
-       ("ruby" ,ruby)))
-    (inputs
-     `(("aspell" ,aspell)
-       ("enchant" ,enchant-1.6)
-       ("hunspell" ,hunspell)
-       ("libidn" ,libidn)
-       ("qca" ,qca)
-       ("qtbase" ,qtbase-5)
-       ("qtmultimedia-5" ,qtmultimedia-5)
-       ("qtsvg-5" ,qtsvg-5)
-       ("qtwebkit" ,qtwebkit)
-       ("qtx11extras" ,qtx11extras)
-       ("x11" ,libx11)
-       ("xext" ,libxext)
-       ("xcb" ,libxcb)
-       ("zlib" ,zlib)))
-    (synopsis "Qt-based XMPP Client")
-    (description "Psi is a capable XMPP client aimed at experienced users.
-Its design goals are simplicity and stability.")
-    (home-page "https://psi-im.org")
-    (license license:gpl2+)))
-
 (define-public libgnt
   (package
     (name "libgnt")