[bug#73551,2/8] gnu: kissat: Update to 4.0.1.
Commit Message
* gnu/packages/maths.scm (kissat): Update to 4.0.1.
[#:phases]<patch-source>: Relax regexp to fix test.
---
gnu/packages/maths.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
@@ -9023,7 +9023,7 @@ (define-public minisat
(define-public kissat
(package
(name "kissat")
- (version "3.0.0")
+ (version "4.0.1")
(source
(origin
(method git-fetch)
@@ -9033,7 +9033,7 @@ (define-public kissat
(file-name (git-file-name name version))
(sha256
(base32
- "04x4w760srbdi4zci0s747qxk717x5d2x59ixraxh5104s9nyn8b"))))
+ "0acg61cfcjg13if2i375cyl4xvwmabhfhi9z8pnw971046am6bzv"))))
(build-system gnu-build-system)
(inputs (list xz gzip lzip bzip2 p7zip))
(arguments
@@ -9058,7 +9058,7 @@ (define-public kissat
"bool found = true;"))
(substitute* "test/testmain.c"
;; SIGINT is ignored inside invoke.
- (("^SIGNAL\\(SIGINT\\)") ""))))
+ (("^[ \t]*SIGNAL[ \t]*\\(SIGINT\\)") ""))))
(replace 'configure
(lambda* (#:key configure-flags #:allow-other-keys)
;; The configure script does not support standard GNU options.