diff mbox series

[bug#40288,1/1] gnu: Add lxqt-organizer.

Message ID c3c24756-51b3-4f84-b17c-c189194ba9c7@www.fastmail.com
State Work in progress
Headers show
Series [bug#40288,1/1] gnu: Add lxqt-organizer. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Hamzeh Nasajpour March 28, 2020, 4:41 p.m. UTC
* gnu/packages/lxqt.scm (lxqt-organizer): New variable.
---
 gnu/packages/lxqt.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

Comments

Efraim Flashner March 30, 2020, 8:46 a.m. UTC | #1
I didn't realize we had so much of lxqt packaged.

Some comments inline:

On Sat, Mar 28, 2020 at 09:11:06PM +0430, Hamzeh Nasajpour wrote:
> * gnu/packages/lxqt.scm (lxqt-organizer): New variable.
> ---
>  gnu/packages/lxqt.scm | 34 ++++++++++++++++++++++++++++++++++
>  1 file changed, 34 insertions(+)
> 
> diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
> index a440491633..7ef6ca51ce 100644
> --- a/gnu/packages/lxqt.scm
> +++ b/gnu/packages/lxqt.scm
> @@ -1269,6 +1269,40 @@ QTermWidget.")
>  easily publishing them on internet image hosting services.")
>      (license license:gpl2+)))
>  
> +(define-public lxqt-organizer
> +  (package
> +    (name "lxqt-organizer")
> +    (version "v0.003")

The author seems to be using this time to do some rapid development and
has already (at the time I checked) already bumped the version to
v0.6.0. Can you update to the most recent version?

> +    (source
> +      (origin
> +        (method git-fetch)
> +        (uri (git-reference
> +               (url (string-append "https://github.com/lxqt/organizer.git"))
> +               (commit "5aa556aa0f0409e00fac5b63d9118ff228d2e840")
> +               (recursive? #t)))

I was going to mention using the version string for the commit but it
seems they haven't pushed any tags to the repo. Can you add a comment
saying they haven't tagged any releases in git? Also, it doesn't look
like there are any submodules so you don't need 'recursive? #t'

> +        (file-name (git-file-name name version))
> +        (sha256
> +          (base32 "1czs9gca7aqsfcnxhi7nzq97pxbmhfgbfh00j7nl8cig0yxb6apv"))))
> +    (build-system cmake-build-system)
> +    (inputs
> +      `(("kwindowsystem" ,kwindowsystem)
> +        ("liblxqt" ,liblxqt)
> +        ("libqtxdg" ,libqtxdg)
> +        ("qtbase" ,qtbase)
> +        ("qtsvg" ,qtsvg)
> +        ;;("qtlinguist" ,qttools)
> +        ("qtx11extras" ,qtx11extras)))

guix gc --references /path/to/item doesn't list all the inputs, so many
of them can actually be moved to native-inputs.

> +    (native-inputs
> +      `(("pkg-config" ,pkg-config)
> +        ("lxqt-build-tools" ,lxqt-build-tools)
> +        ("qttools" ,qttools)))
> +    (arguments
> +      '(#:tests? #f))

I saw that there were no tests in the repo, please add a note.

> +    (home-page "https://lxqt.org/")

Is there a project-specific home-page? If not I'd recommend just using
the github repo as the home-page.

> +    (synopsis "LXQt Organizer is a lightweight organizer for personal information management.")
Perhaps: "LXQt desktop organizer" or "LXQt organizer for personal
information management" Actually the second sounds clunky. "LXQt
personal information management organizer"

> +    (description
> +     "This package provides a Qt-based application for managing meetings, events and other personal information.")
> +    (license license:lgpl2.1+)))
>  
>  (define-public lxqt-archiver
>    (package
> -- 
> 2.25.1
> 

In addition, in the desktop file (in %out/share/application/) there's a
second exec line which starts /usr/local/lxqt-organizer. Can you add a
phase to patch that?

Also, 'guix lint' complains about the length of two of the lines and
about the period in the synopsis.
Christopher Baines Nov. 21, 2020, 9:19 a.m. UTC | #2
It's been a few months, is this patch still relevant?

Thanks,

Chris
diff mbox series

Patch

diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index a440491633..7ef6ca51ce 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -1269,6 +1269,40 @@  QTermWidget.")
 easily publishing them on internet image hosting services.")
     (license license:gpl2+)))
 
+(define-public lxqt-organizer
+  (package
+    (name "lxqt-organizer")
+    (version "v0.003")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url (string-append "https://github.com/lxqt/organizer.git"))
+               (commit "5aa556aa0f0409e00fac5b63d9118ff228d2e840")
+               (recursive? #t)))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32 "1czs9gca7aqsfcnxhi7nzq97pxbmhfgbfh00j7nl8cig0yxb6apv"))))
+    (build-system cmake-build-system)
+    (inputs
+      `(("kwindowsystem" ,kwindowsystem)
+        ("liblxqt" ,liblxqt)
+        ("libqtxdg" ,libqtxdg)
+        ("qtbase" ,qtbase)
+        ("qtsvg" ,qtsvg)
+        ;;("qtlinguist" ,qttools)
+        ("qtx11extras" ,qtx11extras)))
+    (native-inputs
+      `(("pkg-config" ,pkg-config)
+        ("lxqt-build-tools" ,lxqt-build-tools)
+        ("qttools" ,qttools)))
+    (arguments
+      '(#:tests? #f))
+    (home-page "https://lxqt.org/")
+    (synopsis "LXQt Organizer is a lightweight organizer for personal information management.")
+    (description
+     "This package provides a Qt-based application for managing meetings, events and other personal information.")
+    (license license:lgpl2.1+)))
 
 (define-public lxqt-archiver
   (package