From 5c8b341c7d39cc88d723788416865e4d9e26b331 Mon Sep 17 00:00:00 2001
From: Vivien Kraus <vivien@planete-kraus.eu>
Date: Thu, 20 Jan 2022 15:39:12 +0100
Subject: [PATCH 01/18] gnu: Add python-imageio-ffmpeg.
* gnu/packages/python-xyz.scm (python-imageio-ffmpeg): New variable.
---
gnu/packages/python-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)
@@ -28678,3 +28678,36 @@ (define-public python-reedsolo
but not binary streams.")
(license license:public-domain)))
+(define-public python-imageio-ffmpeg
+ (package
+ (name "python-imageio-ffmpeg")
+ (version "0.4.5")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "imageio-ffmpeg" version))
+ (sha256
+ (base32
+ "0ff14079izsyxwf6ki68k9a7w5krjlal7lwqvzg2bbddl92l5spj"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'set-ffmpeg-exe
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; There are different strategies to find ffmpeg, we
+ ;; only fix the last resort, "system ffmpeg command"
+ (substitute* "imageio_ffmpeg/_utils.py"
+ (("exe = \"ffmpeg\"")
+ (format #f "exe = ~s"
+ (search-input-file
+ inputs "/bin/ffmpeg")))))))))
+ (inputs (list ffmpeg))
+ (home-page "https://github.com/imageio/imageio-ffmpeg")
+ (synopsis "@samp{ffmpeg} wrapper for Python")
+ (description
+ "The purpose of this project is to provide a simple and reliable
+@samp{ffmpeg} wrapper for working with video files. It implements two simple
+generator functions for reading and writing data from/to ffmpeg, which
+reliably terminate the ffmpeg process when done. It also takes care of
+publishing platform-specific wheels that include the binary @samp{ffmpeg}
+executables.")
+ (license license:bsd-2)))
--
2.34.0