diff mbox series

[bug#72280] gnu: mawk: Add symlink to 'awk'.

Message ID c3256d536ac16b48b91f36185cc18a62a6c36cd2.1721856143.git.zimon.toutoune@gmail.com
State New
Headers show
Series [bug#72280] gnu: mawk: Add symlink to 'awk'. | expand

Commit Message

Simon Tournier July 24, 2024, 9:23 p.m. UTC
Reported by Zack Weinberg.

* gnu/packages/gawk.scm (mawk)[arguments]: Modify phases to add symlink from
'mawk' to 'awk'.

Change-Id: I98e65bf895db9a5a3f36419574fcc21f92a979fc
---
 gnu/packages/gawk.scm | 9 +++++++++
 1 file changed, 9 insertions(+)


base-commit: d007b64356764f49677c78d82643f1125b5353b7
diff mbox series

Patch

diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index 16a4ca5b0a..94b5439841 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -4,6 +4,7 @@ 
 ;;; Copyright © 2018, 2022 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2021, 2022 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
+;;; Copyright © 2024 Simon Tournier <zimon.toutoune@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -149,6 +150,14 @@  (define-public mawk
                     (("^PATH=.*")
                      ""))))))
     (build-system gnu-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'install 'symlink-awk
+            (lambda _
+              (with-directory-excursion (string-append #$output "/bin")
+                (symlink "mawk" "awk")))))))
     (synopsis "Text scanning and processing language")
     (description
      "@command{mawk} is an interpreter for the Awk programming language.