diff mbox series

[bug#38115] gnu: Add dpf-plugins.

Message ID c2f037599a6739c11ce6435941e43139@posteo.net
State Accepted
Headers show
Series [bug#38115] gnu: Add dpf-plugins. | expand

Commit Message

Alexandros Theodotou Nov. 8, 2019, 8:58 a.m. UTC
From aebc4cded75e51f6c453a52cae10c9224d9e7df9 Mon Sep 17 00:00:00 2001
 From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 8 Nov 2019 08:55:22 +0000
Subject: [PATCH] gnu: Add dpf-plugins.

* gnu/packages/music.scm: (dpf-plugins): New variable.
---
  gnu/packages/music.scm | 47 ++++++++++++++++++++++++++++++++++++++++++
  1 file changed, 47 insertions(+)

+(MaBitcrush, MaFreeverb, MaGigaverb, MaPitchshift), Mini-Series 
(3BandEQ. 3BandSplitter,
+PingPongPan), ndc-Plugs (Amplitude Imposer, Cycle Shifter, Soul Force), 
MVerb, Nekobi,
+and ProM.")
+    (license `(license:isc license:gpl3 license:lgpl3 license:mit 
license:gpl2))))

Comments

Marius Bakke Nov. 10, 2019, 10:45 p.m. UTC | #1
Alexandros Theodotou <alex@zrythm.org> writes:

>  From aebc4cded75e51f6c453a52cae10c9224d9e7df9 Mon Sep 17 00:00:00 2001
>  From: Alexandros Theodotou <alex@zrythm.org>
> Date: Fri, 8 Nov 2019 08:55:22 +0000
> Subject: [PATCH] gnu: Add dpf-plugins.
>
> * gnu/packages/music.scm: (dpf-plugins): New variable.

[...]

> +    (arguments
> +     `(#:tests? #f  ; no "check" target
> +       #:make-flags
> +       (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
> +       #:phases
> +       (modify-phases %standard-phases
> +         (add-after 'unpack 'skip-dssi-binaries
> +           (lambda _
> +             (substitute* "Makefile"
> +                          (("cp -r bin.*-dssi.*$") ":;\n"))
> +             #t))

Can you expand on this comment?  What are these binaries, and why do we
need to prevent them from being installed?

> +    (license `(license:isc license:gpl3 license:lgpl3 license:mit 
> license:gpl2))))

Does this work?  I would expect each of the license entries to have to
be 'unquoted', i.e. `(,license:isc).  Alternatively you can use (list
...) here.

When a package has multiple licenses like here, please add a comment
about it.  Is there a "main" license, (roughly) which files are under
what license?

Apart from that LGTM.
diff mbox series

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index a30765e87f..e78b01d4a3 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -24,6 +24,7 @@ 
  ;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.lonestar.org>
  ;;; Copyright © 2019 raingloom <raingloom@protonmail.com>
  ;;; Copyright © 2019 David Wilson <david@daviwil.com>
+;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
  ;;;
  ;;; This file is part of GNU Guix.
  ;;;
@@ -4699,3 +4700,49 @@  You can also get metadata about the playing track 
such as the artist and title
  for integration into status line generators or other command-line 
tools.")
      (home-page "https://github.com/altdesktop/playerctl")
      (license license:lgpl3+)))
+
+(define-public dpf-plugins
+  (package
+    (name "dpf-plugins")
+    (version "1.3")
+    (source
+      (origin
+        (method git-fetch)
+        (uri
+          (git-reference
+            (url "https://github.com/DISTRHO/DPF-Plugins.git")
+            (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32
+            "0a89hiqflg8y55aphiff64g9jli88lxzwzw4grfk48n7r1mp49hf"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f  ; no "check" target
+       #:make-flags
+       (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'skip-dssi-binaries
+           (lambda _
+             (substitute* "Makefile"
+                          (("cp -r bin.*-dssi.*$") ":;\n"))
+             #t))
+         (add-before 'build 'set-CC-variable
+           (lambda _ (setenv "CC" "gcc") #t))
+             (delete 'configure))))
+    (inputs
+     `(("cairo" ,cairo)
+       ("dssi" ,dssi)
+       ("mesa" ,mesa)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("lv2" ,lv2)))
+    (home-page "https://github.com/DISTRHO/DPF-Plugins")
+    (synopsis "Audio plugin collection")
+    (description "Collection of DPF-based audio plugins in LADSPA, 
DSSI, LV2 and VST2
+formats. This package includes the following plugins: glBars, Kars, 
Max-Gen examples