diff mbox series

[bug#55532] gnu: Add freerct.

Message ID c2a939b78a6ddb841e0d81814fb26e0aea5c3971.1653019420.git.foo.dogsquared@gmail.com
State Accepted
Headers show
Series [bug#55532] gnu: Add freerct. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Gabriel Arazas May 20, 2022, 4:03 a.m. UTC
* gnu/packages/games.scm (freerct): New variable.
---
 gnu/packages/games.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)


base-commit: b6bfe9ea6a1b19159455b34f1af4ac00ef9b94ab

Comments

Gabriel Arazas May 20, 2022, 9:18 a.m. UTC | #1
I opted into the Git repo instead of the zip archive since I cannot get 
consistent results with it (with the '--rounds=3' flag). The package is 
tested to be built in x86_64. Other architectures are yet to be 
confirmed since I cannot build it successfully.
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index c6d23298ff..c1873d4a02 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -71,6 +71,7 @@ 
 ;;; Copyright © 2022 Yovan Naumovski <yovan@gorski.stream>
 ;;; Copyright © 2022 Roman Riabenko <roman@riabenko.com>
 ;;; Copyright © 2022 zamfofex <zamfofex@twdb.moe>
+;;; Copyright © 2022 Gabriel Arazas <foo.dogsquared@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -12715,3 +12716,37 @@  (define-public liquidwar6
 original, they have been invented by Thomas Colcombet.")
     (home-page "https://www.gnu.org/software/liquidwar6/")
     (license license:gpl3+)))
+
+(define-public freerct
+  (package
+    (name "freerct")
+    (version "0.1")
+    ;; TODO: Use the source code given at the homepage.
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/FreeRCT/FreeRCT")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1szwy2cq4ffp4yxm9pp9vdyia0i5nz0wnppdd1xb9w7v3wa4mywi"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f))
+    (native-inputs (list flex bison))
+    (inputs (list libpng sdl2 sdl2-ttf))
+    (home-page "https://freerct.net/")
+    (synopsis "Theme park management simulation game")
+    (description
+     "FreeRCT is a free and open source game that captures the look and feel
+of the popular games RollerCoaster Tycoon 1 and 2, graphics- and
+gameplay-wise.
+
+In this game, you play as a manager of a theme park, allowing
+you to make a park of your dreams.  The list of responsiblities includes
+managing staff, finances, landscaping, and most importantly: rides. Good
+managers follow the principle of prioritizing the guests' happiness with a
+well-maintained park.  Should they go unwise, a theme park plunge into chaos
+with vandalizing guests and unsafe rides. Which path will you take?")
+    (license license:gpl2)))