[bug#76910,4/4] gnu: Add hypr-darkwindow.

Message ID c22062f3c7bf5d28bc3112f057443f1a2f534fbb.1741580560.git.wongandj@icloud.com
State New
Headers
Series gnu: Add Hyprland plugins |

Commit Message

Andrew Wong March 10, 2025, 4:26 a.m. UTC
  * gnu/packages/wm.scm (hypr-darkwindow): New variable.

Change-Id: Ide445c85047e17b5817580bde896a6c303e6a4cd
---
 gnu/packages/wm.scm | 46 +++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 46 insertions(+)
  

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 49e02f1f93..f21cf03780 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -606,6 +606,52 @@  (define-public hy3
 autotiling.")
     (license license:gpl3)))
 
+(define-public hypr-darkwindow
+  (package
+    (name "hypr-darkwindow")
+    (version "0.47.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/micha4w/Hypr-DarkWindow")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0g7zmzwa9w98wwygzl3wxgc6adh6h5ixrm3b8biimby2z5vwc2fz"))))
+    (build-system gnu-build-system)
+    (native-inputs (list gcc-14 pkg-config))
+    (inputs (list aquamarine
+                  eudev
+                  hyprgraphics
+                  hyprlang
+                  hyprutils
+                  libdrm
+                  libinput
+                  libxkbcommon
+                  mesa
+                  pango
+                  pixman
+                  wayland
+                  hyprland))
+    (arguments
+     (list
+      #:tests? #f
+      #:phases
+      #~(modify-phases %standard-phases
+          (delete 'configure)
+          (replace 'install
+            (lambda* _
+              (install-file "out/hypr-darkwindow.so"
+                            (string-append #$output "/lib")))))))
+    (home-page "https://github.com/micha4w/Hypr-DarkWindow")
+    (synopsis "Hyprland plugin that provides window color inversion")
+    (description
+     "This plugin adds the dispatchers @code{invertwindow WINDOW}
+and @code{invertactivewindow}, which invert the colors of the indicated
+window.")
+    (license license:expat)))
+
 (define-public i3status
   (package
     (name "i3status")