[bug#67755,v6,5/8] gnu: Add nativefiledialog-extended.

Message ID c1ef21c71a53070bbb7bc88e74767018c61a5aa8.1742403600.git.liliana.prikler@gmail.com
State New
Headers
Series gnu: Add imhex |

Commit Message

Liliana Marie Prikler March 19, 2025, 5 p.m. UTC
  * gnu/packages/cpp.scm (nativefiledialog-extended): New variable.

Change-Id: I89ed4554db3ec8075bbb7d50bbfb4b99cae81a27
---
 gnu/packages/cpp.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
  

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 4bf0e7f63fa..afc3c6a3947 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -3692,6 +3692,33 @@  (define-public mpark-variant
 based on the implementation of std::variant in libc++.")
     (license license:boost1.0)))
 
+(define-public nativefiledialog-extended
+  (package
+    (name "nativefiledialog-extended")
+    (version "1.2.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/btzy/nativefiledialog-extended")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "15l0jy3v4p6rgg9dk8zr80lqp51s32ii62cm4s90400ragdgh10v"))))
+    (build-system cmake-build-system)
+    (arguments
+     '(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
+    (native-inputs (list pkg-config))
+    (inputs (list gtk+))
+    (home-page "https://github.com/btzy/nativefiledialog-extended")
+    (synopsis "Native file dialog library with C and C++ bindings")
+    (description
+     "This package provides a library that portably invokes native file open,
+folder select and file save dialogs.  It allows the specification of a default
+file name and location, as well as filters with friendly names (such as
+\"source files\" or \"image files\") where supported.")
+    (license license:zlib)))
+
 (define-public tsl-hopscotch-map
   (package
     (name "tsl-hopscotch-map")