[bug#74728] gnu: python-asyncssh: Disable failing tests on aarch64.
Commit Message
* gnu/packages/ssh.scm (python-asyncssh): Disable failing tests on aarch64.
Change-Id: I9f3a746bdf820c1d357fd655f1ed1ff197327856
---
gnu/packages/ssh.scm | 19 +++++++++++++------
1 file changed, 13 insertions(+), 6 deletions(-)
base-commit: 17d86ac9df841deca4f2f5e173f50bd2461fe680
@@ -820,12 +820,19 @@ (define-public python-asyncssh
(list
#:test-flags
#~(list "-k" (string-join
- ;; TODO Test fails for unknown reason
- (list "not test_confirm"
- ;; Tests fail with: asyncssh.misc.ConnectionLost:
- ;; Connection lost
- "test_get_server_host_key_proxy"
- "test_connect_reverse_proxy")
+ (list
+ ;; TODO Test fails for unknown reason
+ "not test_confirm"
+ #$@(if (target-aarch64?)
+ (list
+ ;; Tests fail with: asyncssh.misc.ConnectionLost:
+ ;; Connection lost
+ "test_connect_non_tcp_sock"
+ "test_connect_reverse_proxy"
+ "test_get_server_auth_methods_no_sockn"
+ "test_get_server_auth_methods_no_sockname"
+ "test_get_server_host_key_proxy")
+ '()))
" and not " ))
#:phases
#~(modify-phases %standard-phases