diff mbox series

[bug#61915,v2,05/13] gnu: emacs-agda2-mode: No longer inherit from agda.

Message ID c1aacf40431282c5ac2cf3ccff9e9da253ad5533.1682851600.git.dev@jpoiret.xyz
State New
Headers show
Series Update agda, add build-system and libraries. | expand

Commit Message

Josselin Poiret April 30, 2023, 10:53 a.m. UTC
From: Josselin Poiret <dev@jpoiret.xyz>

* gnu/packages/agda.scm (emacs-agda2-mode): Remove it. Made no sense, as we only
need the source, which we can refer to without inheriting the whole thing.
---
 gnu/packages/agda.scm | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/agda.scm b/gnu/packages/agda.scm
index eba48da0ff..69d6d22d32 100644
--- a/gnu/packages/agda.scm
+++ b/gnu/packages/agda.scm
@@ -128,10 +128,10 @@  (define-public agda
 
 (define-public emacs-agda2-mode
   (package
-    (inherit agda)
     (name "emacs-agda2-mode")
+    (version (package-version agda))
+    (source (package-source agda))
     (build-system emacs-build-system)
-    (inputs '())
     (arguments
      `(#:phases
        (modify-phases %standard-phases
@@ -140,7 +140,8 @@  (define-public emacs-agda2-mode
     (home-page "https://agda.readthedocs.io/en/latest/tools/emacs-mode.html")
     (synopsis "Emacs mode for Agda")
     (description "This Emacs mode enables interactive development with
-Agda.  It also aids the input of Unicode characters.")))
+Agda.  It also aids the input of Unicode characters.")
+    (license (package-license agda))))
 
 (define-public agda-ial
   (package