diff mbox series

[bug#64559] gnu: freesasa: Fix memerr tests.

Message ID c1869dfdd6a083ccb174e66b46cd53b65b76e966.1689012297.git.david.elsing@posteo.net
State New
Headers show
Series [bug#64559] gnu: freesasa: Fix memerr tests. | expand

Commit Message

David Elsing July 10, 2023, 6:06 p.m. UTC
* gnu/packages/chemistry.scm (freesasa)[arguments]: Add
"CFLAGS=-fno-builtin-malloc" to #:configure-flags.
---
 gnu/packages/chemistry.scm | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

Comments

Bruno Victal July 14, 2023, 2:33 a.m. UTC | #1
Hi David,

On 2023-07-10 19:06, David Elsing wrote:
> +              ;; Some tests rely on replacing malloc with a wrapper which
> +              ;; fails in a controlled way, but this does not work if the call
> +              ;; is replaced.
> +              "CFLAGS=-fno-builtin-malloc")

Have you filed an issue with upstream regarding this?
It looks to me that this is something that should be figured out by the
build system or the unit tests.
David Elsing July 14, 2023, 11:01 p.m. UTC | #2
Bruno Victal <mirai@makinata.eu> writes:

Hello Bruno,

> Have you filed an issue with upstream regarding this?
> It looks to me that this is something that should be figured out by the
> build system or the unit tests.
that's true, I just filed an issue: https://github.com/mittinatten/freesasa/issues/94.

Cheers,
David
David Elsing Feb. 14, 2024, 7:20 p.m. UTC | #3
David Elsing <david.elsing@posteo.net> writes:

> that's true, I just filed an issue: https://github.com/mittinatten/freesasa/issues/94.

I included this patch in another patch series for rdkit, which was now
applied in commit cc772e7f3172a8014e32c7ea3f6626963d4e9e16. The issue
was also fixed upstream.
diff mbox series

Patch

diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index cddccf8aea..431b845989 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -703,7 +703,11 @@  (define-public freesasa
       #~(list "--enable-check"
               "--enable-parser-generator"
               "CXXFLAGS=-std=c++17"
-              "--enable-doxygen")
+              "--enable-doxygen"
+              ;; Some tests rely on replacing malloc with a wrapper which
+              ;; fails in a controlled way, but this does not work if the call
+              ;; is replaced.
+              "CFLAGS=-fno-builtin-malloc")
       #:phases
       #~(modify-phases %standard-phases
           (add-after 'unpack 'remove-libc++-linking