diff mbox series

[bug#67873] llama-cpp: Update to commit 2994f0

Message ID c11efe92c927b3e4eccf08102eb4c7e690986ecc.1702861753.git.atai@atai.org
State New
Headers show
Series [bug#67873] llama-cpp: Update to commit 2994f0 | expand

Commit Message

Andy Tai Dec. 18, 2023, 1:09 a.m. UTC
* gnu/packages/machine-learning.scm (llama-cpp): Update to commit 2994f0

Change-Id: I241752d2ac2aa893933e87111454636f08df1af7
---
 gnu/packages/machine-learning.scm | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)


base-commit: 6ab242609daec00e8bd54f7bff54557c92695724

Comments

Andreas Enge March 8, 2024, 10:12 a.m. UTC | #1
Hello Andy,

I am closing this as a similar patch has been applied already:
commit 6e7484808fa2979bd686aae5b64a71849e9391b9
Author: John Fremlin <john@fremlin.org>
Date:   Tue Feb 13 10:32:12 2024 -0500
    gnu: llama-cpp: Update to 03bf16.
    * gnu/packages/machine-learning.scm (llama-cpp): Update to
    03bf161eb6dea6400ee49c6dc6b69bdcfa9fd3fc.
    [arguments]: Adjust program names.
    Change-Id: I9f5474606dd01be73fbc50813250991e9d248d85
    Signed-off-by: Ludovic Courtès <ludo@gnu.org>

Probably your commit is more recent; at the same time for a project
without releases or meaningful tags or branches, it is difficult to tell
when we should update, and there is no point in updating all the time.
I would say after a "meaningful" change, to be determined by users of the
software, for instance.

Thanks,

Andreas
diff mbox series

Patch

diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index c100e0be6e..dbac325eb3 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -516,8 +516,8 @@  (define-public guile-aiscm-next
   (deprecated-package "guile-aiscm-next" guile-aiscm))
 
 (define-public llama-cpp
-  (let ((commit "f31b5397143009d682db90fd2a6cde83f1ef00eb")
-        (revision "0"))
+  (let ((commit "2994f0c5a2e8c96955b422dedc93ec2595d16b82")
+        (revision "1"))
     (package
       (name "llama-cpp")
       (version (git-version "0.0.0" revision commit))
@@ -526,10 +526,10 @@  (define-public llama-cpp
          (method git-fetch)
          (uri (git-reference
                (url "https://github.com/ggerganov/llama.cpp")
-               (commit (string-append "master-" (string-take commit 7)))))
+               (commit commit)))
          (file-name (git-file-name name version))
          (sha256
-          (base32 "0ys6n53n032zq1ll9f3vgxk8sw0qq7x3fi7awsyy13adzp3hn08p"))))
+          (base32 "0g02jh9qz74vmvqh4485jsfcg26r02hn5sji4ckzsnkv627rw9mz"))))
       (build-system cmake-build-system)
       (arguments
        (list
@@ -556,7 +556,6 @@  (define-public llama-cpp
                                       (get-string-all input))))))
                       (chmod (string-append bin script) #o555)))
                   (mkdir-p bin)
-                  (make-script "convert-pth-to-ggml")
                   (make-script "convert-lora-to-ggml")
                   (make-script "convert"))))
             (add-after 'install-python-scripts 'wrap-python-scripts