[bug#77287] gnu: hdf5: Make hdf@1.14 the default version.
Commit Message
* gnu/packages/maths.scm (hdf5-1.14): Rename to...
(hdf5): ...this, which was previously defined as hdf5-1.10.
(hdf-eos5, hdf5-parallel-openmpi, scilab): Adapt variable names.
Change-Id: Ie43a13ecbb4da597ec1d3f7c0428102b45881485
---
The following patch makes hdf5@1.14 the default, so that packages will
depend on this version instead of hdf5@1.10. We need to check which
dependents fail to build; for the time being, we can then replace their
inputs with hdf5@1.10. In the long run, this version of hdf5 should be
removed since it is not maintained any more, see
https://issues.guix.gnu.org/64448
This patch also does not update hdf-java.
gnu/packages/maths.scm | 14 +++++---------
1 file changed, 5 insertions(+), 9 deletions(-)
base-commit: ea41557c9f8bb8670e25a389a408d0112ea6aa34
Comments
Hi Andreas,
Would like to wait QA to pick up this issue?
I'll give it a go to build "guix build -P1 hdf5" mean while.
--
Oleg
Am Wed, Mar 26, 2025 at 09:25:04PM +0000 schrieb Sharlatan Hellseher:
> Would like to wait QA to pick up this issue?
Maybe. QA is working so poorly right now that I think it would make more
sense to let it handle contributions by people who are not committers.
> I'll give it a go to build "guix build -P1 hdf5" mean while.
Hold back, I am doing it already, and replacing back hdf5-1.10 as input
for packages that do not compile with hdf5@1.14. So far I have found
fast5 and ncbi-vdb. I will keep you (and this issue) updated.
The package that might need more work is hdf-java; I think we should
update it to 1.14, preferably in the same commit series. It has a very
long recipe, and in case we cannot simply update the source, but need to
modify the code, I am afraid this will be quite time consuming.
Andreas
@@ -1795,7 +1795,7 @@ (define-public hdf5-1.10
(base32 "14gih7kmjx4h3lc7pg4fwcl28hf1qqkf2x7rljpxqvzkjrqbxi00"))
(patches (search-patches "hdf5-config-date.patch"))))))
-(define-public hdf5-1.14
+(define-public hdf5
(package
(inherit hdf5-1.8)
(version "1.14.3")
@@ -1833,10 +1833,6 @@ (define-public hdf5-1.14
(("@UNAME_INFO@")
"Linux"))))))))))
-(define-public hdf5
- ;; Default version of HDF5.
- hdf5-1.10)
-
;; Keep this in sync with the current hdf5 package.
(define-public hdf-java
(package
@@ -2002,7 +1998,7 @@ (define-public hdf-eos5
(list autoconf automake gfortran libtool))
(build-system gnu-build-system)
(inputs
- (list hdf5-1.14 zlib gctp))
+ (list hdf5 zlib gctp))
(arguments
(list
#:configure-flags ''("--enable-install-include" "--enable-shared"
@@ -2037,13 +2033,13 @@ (define-public hdf-eos5
(license (license:non-copyleft home-page))))
(define-public hdf5-parallel-openmpi
- (package/inherit hdf5-1.14 ;use the latest
+ (package/inherit hdf5
(name "hdf5-parallel-openmpi")
(inputs
`(("mpi" ,openmpi)
,@(package-inputs hdf5)))
(arguments
- (substitute-keyword-arguments (package-arguments hdf5-1.14)
+ (substitute-keyword-arguments (package-arguments hdf5)
((#:configure-flags flags)
#~(cons "--enable-parallel"
(delete "--enable-cxx"
@@ -10588,7 +10584,7 @@ (define-public scilab
curl
fftw
gettext-minimal
- hdf5-1.14
+ hdf5
libarchive
libx11
libxml2