diff mbox series

[bug#63457,v1] gnu: rogue: Add 5.4.4

Message ID c0d6d5e86b19e4a5e91bed2683b5b745ec06c887.1684349499.git.jakob.kirsch@web.de
State New
Headers show
Series [bug#63457,v1] gnu: rogue: Add 5.4.4 | expand

Commit Message

Jakob Kirsch May 17, 2023, 6:52 p.m. UTC
fix the guix lint warning

---
 gnu/packages/games.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)


base-commit: 0540f4e20de3172ea09e27182e98b66b73c92421
--
2.39.2
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index d1e2248588..5048075081 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -877,6 +877,29 @@  (define-public bsd-games
               ;; phantasia (all but phantasia/pathnames.h.in, which is bsd-3)
               (license:fsf-free "file:///phantasia/COPYRIGHT")))))

+(define-public rogue
+  (package
+    (name "rogue")
+    (version "5.4.4")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/Davidslv/rogue")
+                    (commit "cf9bd26d564a72fac4cf56b55c96c2435270d29a")))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0mk03l120scas4dcn6xccnhslnwmcx2blshbf925z06yk7rkzias"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f
+       #:make-flags (list "CFLAGS=-DNCURSES_INTERNALS")))
+    (inputs (list ncurses))
+    (synopsis "Original Rogue Game (5.4.4)")
+    (description "Rogue 5.4.4: Exploring the Dungeons of Doom")
+    (home-page "https://github.com/Davidslv/rogue")
+    (license license:bsd-3)))
+

 (define-public bzflag
   (package