diff mbox series

[bug#42453] gnu: chroma: Fix build.

Message ID c08ee7fe-3df7-bebf-05b3-2936d651156d@gmail.com
State Accepted
Headers show
Series [bug#42453] gnu: chroma: Fix build. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Jesse Gibbons July 21, 2020, 6:56 p.m. UTC
Attached is a patch that fixes the build of Chroma in gnu/packaes/games.scm

Comments

Brett Gilio July 25, 2020, 1:19 a.m. UTC | #1
Jesse Gibbons <jgibbons2357@gmail.com> writes:

> Attached is a patch that fixes the build of Chroma in gnu/packaes/games.scm

Hi Jesse!

Thanks for submitting the unmangled patch! I have reviewed it and pushed
it to master with 982a6e79a2d674ea905e2c63c2378b9df7d64af6. Along with
the push I revised the git commit message and sub-header to be more
descriptive. Thank you, again!

Brett Gilio
diff mbox series

Patch

From 42d71e4945d5a315ebf3b986082dbbbe99e7d392 Mon Sep 17 00:00:00 2001
From: Jesse Gibbons <jgibbons2357+guix@gmail.com>
Date: Mon, 20 Jul 2020 20:38:30 -0600
Subject: [PATCH 1/1] gnu: chroma: Fix build.

* gnu/packages/games.scm: chroma:
[configure-flags]: Add "CFLAGS=-fgnu89-inline"
---
 gnu/packages/games.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index f4d75eedd4..cff1c0af99 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -40,7 +40,7 @@ 
 ;;; Copyright © 2019, 2020 Oleg Pykhalov <go.wigust@gmail.com>
 ;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
-;;; Copyright © 2019 Jesse Gibbons <jgibbons2357+guix@gmail.com>
+;;; Copyright © 2019, 2020 Jesse Gibbons <jgibbons2357+guix@gmail.com>
 ;;; Copyright © 2019 Dan Frumin <dfrumin@cs.ru.nl>
 ;;; Copyright © 2019, 2020 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2019, 2020 Timotej Lazar <timotej.lazar@araneo.si>
@@ -5895,7 +5895,8 @@  with the mouse isn’t always trivial.")
                 "047sf00x71xbmi8bqrhfbmr9bk89l2gbykkqsfpw4wz6yfjscs6y"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f))                    ; no tests included
+     `(#:tests? #f                      ; no tests included
+       #:configure-flags '("CFLAGS=-fgnu89-inline"))) ; fix inlines
     (inputs
      `(("sdl-union" ,(sdl-union (list sdl sdl-image sdl-mixer sdl-ttf)))
        ("freetype" ,freetype)
-- 
2.27.0