diff mbox series

[bug#69932] gnu: shellutils: Add process-compose 0.88.0.

Message ID c07818ffd76f6717d7d80ad4ad2cc5bb@lyrion.ch
State New
Headers show
Series [bug#69932] gnu: shellutils: Add process-compose 0.88.0. | expand

Commit Message

Daniel Ziltener March 21, 2024, 6:16 p.m. UTC
---
 gnu/packages/shellutils.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

Dale Mellor April 6, 2024, 7 p.m. UTC | #1
Hello,

   you need to understand that Guix can only take scrutable source as its
inputs, so that it can build binaries with a known specific build
infrastructure; all of this information needs to be available so that hashes can
be computed for the package which are tamper-evident and anyone must be able to
reproduce the exact hash under the same conditions, if they wish it, for their
own peace of mind.

   Thus this trivial-build dump-from-tarbomb approach cannot be accepted; the
package should be pulled directly from its GIT repository, and full build
instructions need to be provided to the Guix package management system.

   Please look at how other Go-sourced packages are done for some inspiration.

Thank you.
Leo Famulari April 7, 2024, 2:13 p.m. UTC | #2
On Sat, Apr 06, 2024 at 08:00:42PM +0100, Dale Mellor wrote:
>    you need to understand that Guix can only take scrutable source as its
> inputs, so that it can build binaries with a known specific build
> infrastructure; all of this information needs to be available so that hashes can
> be computed for the package which are tamper-evident and anyone must be able to
> reproduce the exact hash under the same conditions, if they wish it, for their
> own peace of mind.
> 
>    Thus this trivial-build dump-from-tarbomb approach cannot be accepted; the
> package should be pulled directly from its GIT repository, and full build
> instructions need to be provided to the Guix package management system.

To summarize, the package needs to build process-compose from source.
Please feel free to ask for help if necessary.
Daniel Ziltener April 16, 2024, 10:01 a.m. UTC | #3
close 69932

thanks
diff mbox series

Patch

diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index e58e9e61fc..fc8c1bc0f1 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -539,6 +539,34 @@  (define-public direnv
 environment variables of the current shell.")
     (license license:expat)))
 
+(define-public process-compose
+  (package
+    (name "process-compose")
+    (version "0.88.0")
+    (source
+     (origin
+       (method url-fetch/tarbomb)
+       (uri (string-append
+             "https://github.com/F1bonacc1/process-compose/releases/download/v"
+             version "/process-compose_linux_amd64.tar.gz"))
+       (sha256
+        (base32
+         "1qhfrbd5ybb0sinl9pad64rscr08qvlfzrzmi4p4hk61xn6phlmz"))))
+    (build-system trivial-build-system)
+    (arguments
+     (list
+      #:modules '((guix build utils))
+      #:builder #~(let ((source (assoc-ref %build-inputs "source"))
+                        (output (assoc-ref %outputs "out")))
+                    (use-modules (guix build utils))
+                    (install-file
+                     (string-append source "/process-compose") output))))
+    (home-page "https://f1bonacc1.github.io/process-compose")
+    (synopsis "Scheduler and orchestrator for processes")
+    (description "Process Compose is a simple and flexible scheduler and orchestrator
+to manage non-containerized applications.")
+    (license license:expat)))
+
 (define-public fzy
   (package
     (name "fzy")