diff mbox series

[bug#48653] gnu: emacs-forge: Update to 0.2.0.

Message ID c0612f250830cdca458470bb10cf73a0163b1fde.1621954934.git.public@yoctocell.xyz
State Accepted
Headers show
Series [bug#48653] gnu: emacs-forge: Update to 0.2.0. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen May 25, 2021, 3:03 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-forge): Update to 0.2.0.
[arguments]<#:phases>: Don’t return #t at the end of phases, this will be
redundant once core-updates gets merged.
---
 gnu/packages/emacs-xyz.scm | 86 +++++++++++++++++++-------------------
 1 file changed, 42 insertions(+), 44 deletions(-)


base-commit: 0ffac75ece4f22a8595e19b8a375791e87d365aa

Comments

Nicolas Goaziou May 26, 2021, 12:49 p.m. UTC | #1
Hello,

Xinglu Chen <public@yoctocell.xyz> writes:

> * gnu/packages/emacs-xyz.scm (emacs-forge): Update to 0.2.0.
> [arguments]<#:phases>: Don’t return #t at the end of phases, this will be
> redundant once core-updates gets merged.

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 886320cc34..9d5774d66e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22969,51 +22969,49 @@  commands (a prefix and a suffix) we prefer to call it just a \"transient\".")
     (license license:gpl3+)))
 
 (define-public emacs-forge
-  (let ((commit "05ef02913004826165c383bd6d2ff6574542b76c"))
-    (package
-      (name "emacs-forge")
-      (version (git-version "0.1.0" "5" commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://github.com/magit/forge")
-               (commit commit)))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32
-           "1vv7xlawj2zmwqk69qlsqflhh0lbyqm5xf4x8l4v2069g0k8mmx1"))))
-      (build-system emacs-build-system)
-      (native-inputs
-       `(("texinfo" ,texinfo)))
-      (propagated-inputs
-       `(("emacs-closql" ,emacs-closql)
-         ("emacs-dash" ,emacs-dash)
-         ("emacs-emacsql-sqlite" ,emacs-emacsql)
-         ("emacs-ghub" ,emacs-ghub)
-         ("emacs-let-alist" ,emacs-let-alist)
-         ("emacs-magit" ,emacs-magit)
-         ("emacs-markdown-mode" ,emacs-markdown-mode)
-         ("emacs-transient" ,emacs-transient)))
-      (arguments
-       `(#:tests? #f ;no tests
-         #:phases
-         (modify-phases %standard-phases
-           (add-after 'unpack 'build-info-manual
-             (lambda _
-               (invoke "make" "info")
-               ;; Move the info file to lisp so that it gets installed by the
-               ;; emacs-build-system.
-               (rename-file "docs/forge.info" "lisp/forge.info")))
-           (add-after 'build-info-manual 'chdir-lisp
-             (lambda _
-               (chdir "lisp")
-               #t)))))
-      (home-page "https://github.com/magit/forge/")
-      (synopsis "Access Git forges from Magit")
-      (description "Work with Git forges, such as Github and Gitlab, from the
+  (package
+     (name "emacs-forge")
+     (version "0.2.0")
+     (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+              (url "https://github.com/magit/forge")
+              (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32
+          "139pndj9l9aifnvv2ak5zwf5gzwhp3m6dfpw1avf4vkh1zywzwa0"))))
+     (build-system emacs-build-system)
+     (native-inputs
+      `(("texinfo" ,texinfo)))
+     (propagated-inputs
+      `(("emacs-closql" ,emacs-closql)
+        ("emacs-dash" ,emacs-dash)
+        ("emacs-emacsql-sqlite" ,emacs-emacsql)
+        ("emacs-ghub" ,emacs-ghub)
+        ("emacs-let-alist" ,emacs-let-alist)
+        ("emacs-magit" ,emacs-magit)
+        ("emacs-markdown-mode" ,emacs-markdown-mode)
+        ("emacs-transient" ,emacs-transient)))
+     (arguments
+      `(#:tests? #f                     ;no tests
+        #:phases
+        (modify-phases %standard-phases
+          (add-after 'unpack 'build-info-manual
+            (lambda _
+              (invoke "make" "info")
+              ;; Move the info file to lisp so that it gets installed by the
+              ;; emacs-build-system.
+              (rename-file "docs/forge.info" "lisp/forge.info")))
+          (add-after 'build-info-manual 'chdir-lisp
+            (lambda _
+              (chdir "lisp"))))))
+     (home-page "https://github.com/magit/forge/")
+     (synopsis "Access Git forges from Magit")
+     (description "Work with Git forges, such as Github and Gitlab, from the
 comfort of Magit and the rest of Emacs.")
-      (license license:gpl3+))))
+     (license license:gpl3+)))
 
 (define-public emacs-matcha
   (let ((commit "c7df5cf5cdac9ae369e241342389ccda0205eab9"))