diff mbox series

[bug#66830] gnu: Transmission: Update to 4.0.4.

Message ID c059fe649dbf900080699c7bd2589a12c17e6412.1698641246.git.leo@famulari.name
State New
Headers show
Series [bug#66830] gnu: Transmission: Update to 4.0.4. | expand

Commit Message

Leo Famulari Oct. 30, 2023, 4:47 a.m. UTC
* gnu/packages/bittorrent.scm (transmission): Update to 4.0.4.
[synopsis]: Remove "marketing phrases".

Change-Id: Ibecdf14198ba926eea66ff5ba29ec05fbd27fde2
---
 gnu/packages/bittorrent.scm | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

Comments

Christopher Baines Oct. 30, 2023, 11:36 a.m. UTC | #1
Leo Famulari <leo@famulari.name> writes:

> * gnu/packages/bittorrent.scm (transmission): Update to 4.0.4.
> [synopsis]: Remove "marketing phrases".
>
> Change-Id: Ibecdf14198ba926eea66ff5ba29ec05fbd27fde2
> ---
>  gnu/packages/bittorrent.scm | 11 ++++++-----
>  1 file changed, 6 insertions(+), 5 deletions(-)

This looks good to me, I made Transmission lower case in the commit
message (to match the package/variable name) and pushed it to master as
5746d043a6433d1103dd8edf46df0b39c8bd3c7f.

I also retried some builds on the bordeaux build farm, as there were
some failures blocking building this.

Thanks,

Chris
diff mbox series

Patch

diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index b357d96fbc..abf8a609e9 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -83,7 +83,7 @@  (define-module (gnu packages bittorrent)
 (define-public transmission
   (package
     (name "transmission")
-    (version "4.0.3")
+    (version "4.0.4")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/transmission/transmission"
@@ -91,7 +91,7 @@  (define-public transmission
                                   version ".tar.xz"))
               (sha256
                (base32
-                "0njlmpcdsxwx8vwdk9dvsby51l6f6awks9d0mgvi9fs2ivaizc5n"))))
+                "19nm7f4x3zq610da5fl63vpycj4kv07np6ldm8czpgyziwqv9xqm"))))
     (build-system cmake-build-system)
     (outputs '("out"                      ; library and command-line interface
                "gui"))                    ; graphical user interface
@@ -112,8 +112,9 @@  (define-public transmission
            (replace 'check
              (lambda* (#:key tests? parallel-tests? #:allow-other-keys)
                (if tests?
-                   ;; XXX this test fails...
-                   (invoke "ctest" "-E" "usesBootstrapFile"
+                   (invoke "ctest"
+                           ;; XXX this test fails...
+                           "-E" "usesBootstrapFile"
                            "-j" (if parallel-tests?
                                     (number->string (parallel-job-count))
                                     "1"))
@@ -155,7 +156,7 @@  (define-public transmission
     (native-inputs
      (list intltool pkg-config))
     (home-page "https://transmissionbt.com/")
-    (synopsis "Fast and easy BitTorrent client")
+    (synopsis "BitTorrent client")
     (description
      "Transmission is a BitTorrent client that comes with graphical,
 textual, and Web user interfaces.  Transmission also has a daemon for