diff mbox series

[bug#66194] gnu: lhasa: Update to 0.4.0.

Message ID c01b1116a5abb21e7b0928cfcb58279f230a8c0e.1695664069.git.hendursaga@aol.com
State New
Headers show
Series [bug#66194] gnu: lhasa: Update to 0.4.0. | expand

Commit Message

Hendursaga Sept. 25, 2023, 5:48 p.m. UTC
* gnu/packages/compression.scm (lhasa): Update to 0.4.0.
[arguments]: Use G-expressions.
[home-page]: Switch to github.io.
[description]: Add Texinfo markup.
---
 gnu/packages/compression.scm | 35 +++++++++++++++++------------------
 1 file changed, 17 insertions(+), 18 deletions(-)


base-commit: 1d872a67054291bf05ef00185b60f73d6608bf18

Comments

Christopher Baines Sept. 27, 2023, 11:50 a.m. UTC | #1
Hendursaga via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/compression.scm (lhasa): Update to 0.4.0.
> [arguments]: Use G-expressions.
> [home-page]: Switch to github.io.
> [description]: Add Texinfo markup.
> ---
>  gnu/packages/compression.scm | 35 +++++++++++++++++------------------
>  1 file changed, 17 insertions(+), 18 deletions(-)

Thanks for the patch, I've pushed this to master as
5c3e4c826f35a7eaace878b1782dd3cb66bd74fa.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index beaac3fccb..43e02b895d 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -542,7 +542,7 @@  (define-public xz
 (define-public lhasa
   (package
     (name "lhasa")
-    (version "0.3.1")
+    (version "0.4.0")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -550,26 +550,25 @@  (define-public lhasa
                     version "/lhasa-" version ".tar.gz"))
               (sha256
                (base32
-                "092zi9av18ma20c6h9448k0bapvx2plnp292741dvfd9hmgqxc1z"))))
+                "1cy5429c7h1dp4l5y9ncdy40qarl9ix31ylkzdi8al2c60y8iz57"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         (add-before 'check 'set-up-test-environment
-           (lambda* (#:key inputs #:allow-other-keys)
-             (setenv "TZDIR"
-                     (search-input-directory inputs
-                                             "share/zoneinfo")))))))
-    (native-inputs
-     (list tzdata-for-tests))
-    (home-page "https://fragglet.github.com/lhasa/")
+     (list #:phases #~(modify-phases %standard-phases
+                        (add-before 'check 'set-up-test-environment
+                          (lambda* (#:key inputs #:allow-other-keys)
+                            (setenv "TZDIR"
+                                    (search-input-directory inputs
+                                                            "share/zoneinfo")))))))
+    (native-inputs (list tzdata-for-tests))
+    (home-page "https://fragglet.github.io/lhasa/")
     (synopsis "LHA archive decompressor")
-    (description "Lhasa is a replacement for the Unix LHA tool, for
-decompressing .lzh (LHA / LHarc) and .lzs (LArc) archives.  The backend for the
-tool is a library, so that it can be reused for other purposes.  Lhasa aims to
-be compatible with as many types of lzh/lzs archives as possible.  It also aims
-to generate the same output as the (non-free) Unix LHA tool, so that it will
-act as a free drop-in replacement.")
+    (description
+     "Lhasa is a replacement for the Unix LHa tool, for decompressing
+@file{.lzh} (LHA / LHarc) and .lzs (LArc) archives.  The backend for the tool is
+a library, so that it can be reused for other purposes.  Lhasa aims to be
+compatible with as many types of @file{.lzh}/@file{lzs} archives as possible.
+It also aims to generate the same output as the (non-free) Unix @command{lha}
+tool, so that it will act as a free drop-in replacement.")
     (license license:isc)))
 
 (define-public lzo