diff mbox series

[bug#57085] gnu: Add texlive-biblatex-apa.

Message ID c017c4b4-78df-074e-205e-ab2e267265d9@toregilhk.org
State Accepted
Headers show
Series [bug#57085] gnu: Add texlive-biblatex-apa. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Tor Egil Hoftun Kvæstad Aug. 9, 2022, 5:07 p.m. UTC
* gnu/packages/tex.scm (texlive-biblatex-apa): New variable.
---
 gnu/packages/tex.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

   (let ((template (simple-texlive-package
                    "texlive-todonotes"

base-commit: f194df2bb44d61ed17222d4ac1b4bc739fdc3f97

Comments

Ludovic Courtès Aug. 31, 2022, 9:26 p.m. UTC | #1
Hi,

Tor Egil Hoftun Kvæstad <me@toregilhk.org> skribis:

> * gnu/packages/tex.scm (texlive-biblatex-apa): New variable.

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6d3572cf25..1b3c086d54 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -9682,6 +9682,28 @@  (define-public texlive-biblatex
 @end enumerate\n")
       (license license:lppl1.3c))))

+(define-public texlive-biblatex-apa
+  (package
+    ;; Version 9.16 2022-06-22
+    (inherit (simple-texlive-package
+              "texlive-biblatex-apa"
+              (list "doc/latex/biblatex-apa/"
+                    "tex/latex/biblatex-apa/")
+              (base32
+               "0ivf7xbzj4xd57sqfbi87hbr73rraqifkzvx06yxgq0gmzz0x6wl")
+              #:trivial? #t))
+    (propagated-inputs
+     (list texlive-biblatex biber texlive-csquotes))
+    (home-page
+     "https://www.ctan.org/pkg/biblatex-apa")
+    (synopsis "BibLaTeX citation and reference style for APA")
+    (description
+     "This is a fairly complete BibLaTeX style (citations and
references) for
+@acronym{APA, American Psychological Association} publications.  It
implements
+and automates most of the guidelines in the APA 7th edition style guide for
+citations and references.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-todonotes