diff mbox series

[bug#50388,core-updates-frozen] gnu: lablgtk: Update to 2.18.11.

Message ID c007a59c377a9224b571012c11a42951c73f6dce.1630804864.git.iskarian@mgsn.dev
State Accepted
Headers show
Series [bug#50388,core-updates-frozen] gnu: lablgtk: Update to 2.18.11. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Sarah Morgensen Sept. 5, 2021, 1:25 a.m. UTC
Update lablgtk to fix compilation with GCC 10.

* gnu/packages/ocaml.scm (lablgtk): Update to 2.18.11.
---
This should fix lablgtk, ocaml4.07-lablgtk, and 43 dependents (assuming they
don't have other build issues).

I don't have the spare cycles to build this out right now, but the only code
change the update contains is the GCC 10 fix [0].

[0] https://github.com/garrigue/lablgtk/commit/1569736

--
Sarah

 gnu/packages/ocaml.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)


base-commit: 68dd6d809398297dc2ebef522186c9b9f2566739

Comments

Guillaume Le Vaillant Sept. 5, 2021, 9:11 a.m. UTC | #1
Patch pushed as c1b350afc64a08d7fda835492f3c6ec1d2d28697.
Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 82ee34c542..ada52b291e 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -23,6 +23,7 @@ 
 ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
 ;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
 ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1089,7 +1090,7 @@  Knuth’s LR(1) parser construction technique.")
 (define-public lablgtk
   (package
     (name "lablgtk")
-    (version "2.18.10")
+    (version "2.18.11")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -1098,7 +1099,7 @@  Knuth’s LR(1) parser construction technique.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0w8cdfcv2wc19sd3qzj3qq77qc6rbnbynsz02gzbl15kgrvgrfxi"))))
+                "179ipx0c6bpxm4gz0syxgqy09dp5p4x9qsdil7s9jlx8ffg1mm0w"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("ocaml" ,ocaml)