diff mbox series

[bug#58016] gnu: linux-libre: Support zram on all kernels.

Message ID bff367cb853cd5603c8288d2bf6488ee8737a2df.1663913200.git.efraim@flashner.co.il
State Accepted
Headers show
Series [bug#58016] gnu: linux-libre: Support zram on all kernels. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Efraim Flashner Sept. 23, 2022, 6:08 a.m. UTC
* gnu/packages/linux.scm (%default-extra-linux-options): Add config
options to add zram support.
---

Currently we only have zram support in our kernel .conf files, this adds
it to all the linux-libre-<arch>-generic kernels, and any other ones I
may have forgotten about.

---
 gnu/packages/linux.scm | 4 ++++
 1 file changed, 4 insertions(+)


base-commit: 2e8b4f9bfa00489fd3acff305837a79af236e183

Comments

Ludovic Courtès Oct. 4, 2022, 7:47 a.m. UTC | #1
Hi,

Efraim Flashner <efraim@flashner.co.il> skribis:

> * gnu/packages/linux.scm (%default-extra-linux-options): Add config
> options to add zram support.
> ---
>
> Currently we only have zram support in our kernel .conf files, this adds
> it to all the linux-libre-<arch>-generic kernels, and any other ones I
> may have forgotten about.

Sounds reasonable to me, thanks!

Ludo’.
Efraim Flashner Oct. 6, 2022, 6:50 a.m. UTC | #2
On Tue, Oct 04, 2022 at 09:47:34AM +0200, Ludovic Courtès wrote:
> Hi,
> 
> Efraim Flashner <efraim@flashner.co.il> skribis:
> 
> > * gnu/packages/linux.scm (%default-extra-linux-options): Add config
> > options to add zram support.
> > ---
> >
> > Currently we only have zram support in our kernel .conf files, this adds
> > it to all the linux-libre-<arch>-generic kernels, and any other ones I
> > may have forgotten about.
> 
> Sounds reasonable to me, thanks!
> 
> Ludo’.

Thanks! Patch pushed.
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 306c18e398..18f8efe2f2 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -695,6 +695,10 @@  (define %default-extra-linux-options
     ("CONFIG_PROC_PID_CPUSET" . #t)
     ;; Allow disk encryption by default
     ("CONFIG_DM_CRYPT" . m)
+    ;; Support zram on all kernel configs
+    ("CONFIG_ZSWAP" . #t)
+    ("CONFIG_ZSMALLOC" . #t)
+    ("CONFIG_ZRAM" . m)
     ;; Modules required for initrd:
     ("CONFIG_NET_9P" . m)
     ("CONFIG_NET_9P_VIRTIO" . m)