diff mbox series

[bug#64787,v3,1/2] gnu: Add scummc.

Message ID bfd543b1-21fc-41ca-1a28-3c8f1bf9b1c0@disroot.org
State New
Headers show
Series [bug#64787,v3,1/2] gnu: Add scummc. | expand

Commit Message

Adam Faiz Aug. 27, 2023, 5:27 a.m. UTC
From 7ab2531a5434121f3fb7fdc25c626693f4d96cb6 Mon Sep 17 00:00:00 2001
Message-ID: <7ab2531a5434121f3fb7fdc25c626693f4d96cb6.1693113837.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Sat, 22 Jul 2023 15:34:55 +0800
Subject: [PATCH v3 1/2] gnu: Add scummc.

* gnu/packages/game-development.scm (scummc): New variable.
---
 gnu/packages/game-development.scm | 55 +++++++++++++++++++++++++++++++
 1 file changed, 55 insertions(+)


base-commit: d17eea747277643811134f9a33b534e58160688f

Comments

Liliana Marie Prikler Aug. 27, 2023, 6:21 a.m. UTC | #1
Am Sonntag, dem 27.08.2023 um 13:27 +0800 schrieb Adam Faiz:
> From 7ab2531a5434121f3fb7fdc25c626693f4d96cb6 Mon Sep 17 00:00:00
> 2001
> Message-ID:
> <7ab2531a5434121f3fb7fdc25c626693f4d96cb6.1693113837.git.adam.faiz@di
> sroot.org>
> From: AwesomeAdam54321 <adam.faiz@disroot.org>
> Date: Sat, 22 Jul 2023 15:34:55 +0800
> Subject: [PATCH v3 1/2] gnu: Add scummc.
> 
> * gnu/packages/game-development.scm (scummc): New variable.
> ---
>  gnu/packages/game-development.scm | 55
> +++++++++++++++++++++++++++++++
>  1 file changed, 55 insertions(+)
> 
> diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-
> development.scm
> index 5e470f0d25..3f53b53f3a 100644
> --- a/gnu/packages/game-development.scm
> +++ b/gnu/packages/game-development.scm
> @@ -66,6 +66,7 @@ (define-module (gnu packages game-development)
>    #:use-module (gnu packages autotools)
>    #:use-module (gnu packages base)
>    #:use-module (gnu packages bash)
> +  #:use-module (gnu packages bison)
>    #:use-module (gnu packages boost)
>    #:use-module (gnu packages build-tools)
>    #:use-module (gnu packages compression)
> @@ -745,6 +746,60 @@ (define-public tsukundere
>  experimental.")
>      (license license:lgpl3+)))
>  
> +(define-public scummc
> +  (package
> +    (name "scummc")
> +    (version "0.2.1")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/AlbanBedel/scummc")
> +                    (commit (string-append "v" version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +               
> "1yyq05kfmvgx5aa68kg1l5a4lpsky7hzxxcdvv2xbgf0jljdcl3k"))
> +              (modules '((guix build utils)))
> +              (snippet
> +               #~(begin
> +                   (substitute* "configure"
> +                     (("\\|alpha" all)
> +                      (string-append all
> "|arm|aarch64|powerpc64le")))
> +                   (substitute* "examples/example.mak"
> +                     (("scost.*\n$") "scost\n")
> +                     (("bmp \\$\\(.*\n$") "bmp\n")
> +                     (("/%.scc.*\n$") "/%.scc\n")
> +                     (("voc \\$\\(.*\n$") "voc\n"))
> +                   (substitute* "Makefile.target"
> +                     (("distrib-data:.*\n") "distrib-data:\n")
> +                     (("cp.*/bin" all)
> +                      (string-append all " || true")))))))
> +    (build-system gnu-build-system)
> +    (native-inputs
> +     (list bison doxygen libxslt pkg-config))
> +    (inputs
> +     (list freetype gtk+-2 sdl))
The preferred order is build-system, arguments, inputs, native-inputs.
> +    (arguments
> +     (list #:test-target "test"
> +           #:tests? #f ; The only tests verify that game checksums
> match
> +           #:make-flags
> +           #~(list "SHOW_WARNINGS=no")
> +           #:phases
> +           #~(modify-phases %standard-phases
> +               (replace 'configure ; ScummC uses a non-standard
> configure
> +                    (lambda* (#:key configure-flags #:allow-other-
> keys)
> +                      (apply invoke  "./configure" configure-
> flags)))
> +               (replace 'install ; install target is referred to as
> distrib
> +                 (lambda _
> +                   (invoke "make" "distrib"
> +                           (string-append "DISTRIB=" #$output)))))))
> +    (synopsis "Scumm Compiler")
Should probably be SCUMM Compiler, no?
> +    (description
> +     "ScummC is a set of tools allowing to create SCUMM games from
> scratch.
> +It is capable of creating games for SCUMM version 6 and partially
> version 7.")
> +    (home-page "https://github.com/AlbanBedel/scummc")
> +    (license license:gpl2+)))
> +
Otherwise LGTM.
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 5e470f0d25..3f53b53f3a 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -66,6 +66,7 @@  (define-module (gnu packages game-development)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
   #:use-module (gnu packages bash)
+  #:use-module (gnu packages bison)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages build-tools)
   #:use-module (gnu packages compression)
@@ -745,6 +746,60 @@  (define-public tsukundere
 experimental.")
     (license license:lgpl3+)))
 
+(define-public scummc
+  (package
+    (name "scummc")
+    (version "0.2.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/AlbanBedel/scummc")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1yyq05kfmvgx5aa68kg1l5a4lpsky7hzxxcdvv2xbgf0jljdcl3k"))
+              (modules '((guix build utils)))
+              (snippet
+               #~(begin
+                   (substitute* "configure"
+                     (("\\|alpha" all)
+                      (string-append all "|arm|aarch64|powerpc64le")))
+                   (substitute* "examples/example.mak"
+                     (("scost.*\n$") "scost\n")
+                     (("bmp \\$\\(.*\n$") "bmp\n")
+                     (("/%.scc.*\n$") "/%.scc\n")
+                     (("voc \\$\\(.*\n$") "voc\n"))
+                   (substitute* "Makefile.target"
+                     (("distrib-data:.*\n") "distrib-data:\n")
+                     (("cp.*/bin" all)
+                      (string-append all " || true")))))))
+    (build-system gnu-build-system)
+    (native-inputs
+     (list bison doxygen libxslt pkg-config))
+    (inputs
+     (list freetype gtk+-2 sdl))
+    (arguments
+     (list #:test-target "test"
+           #:tests? #f ; The only tests verify that game checksums match
+           #:make-flags
+           #~(list "SHOW_WARNINGS=no")
+           #:phases
+           #~(modify-phases %standard-phases
+               (replace 'configure ; ScummC uses a non-standard configure
+                    (lambda* (#:key configure-flags #:allow-other-keys)
+                      (apply invoke  "./configure" configure-flags)))
+               (replace 'install ; install target is referred to as distrib
+                 (lambda _
+                   (invoke "make" "distrib"
+                           (string-append "DISTRIB=" #$output)))))))
+    (synopsis "Scumm Compiler")
+    (description
+     "ScummC is a set of tools allowing to create SCUMM games from scratch.
+It is capable of creating games for SCUMM version 6 and partially version 7.")
+    (home-page "https://github.com/AlbanBedel/scummc")
+    (license license:gpl2+)))
+
 (define-public sfml
   (package
     (name "sfml")