diff mbox series

[bug#71212] gnu: aide: Update to 0.18.8.

Message ID bfcf53b5fbbf3cfe880f23783d8c60bd9fa7fdac.1716743854.git.poptsov.artyom@gmail.com
State New
Headers show
Series [bug#71212] gnu: aide: Update to 0.18.8. | expand

Commit Message

Artyom V. Poptsov May 26, 2024, 5:17 p.m. UTC
* gnu/packages/admin.scm (aide): Update to 0.18.8.
  [native-inputs]: Add "pkg-config".
  [inputs]: Use "pcre2".

Change-Id: I15ae1d86ea9fdfed16e901c041bae292ec68a742
---
 gnu/packages/admin.scm | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)


base-commit: dc8fb5672464b6386f6b4b94723f9b36edc4e625

Comments

Zheng Junjie May 29, 2024, 4:47 a.m. UTC | #1
"Artyom V. Poptsov" <poptsov.artyom@gmail.com> writes:

> * gnu/packages/admin.scm (aide): Update to 0.18.8.
>   [native-inputs]: Add "pkg-config".
>   [inputs]: Use "pcre2".
>
> Change-Id: I15ae1d86ea9fdfed16e901c041bae292ec68a742
> ---
>  gnu/packages/admin.scm | 9 ++++-----
>  1 file changed, 4 insertions(+), 5 deletions(-)
>
> diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
> index bae9ee1308..4d4fbf55ac 100644
> --- a/gnu/packages/admin.scm
> +++ b/gnu/packages/admin.scm
> @@ -234,23 +234,22 @@ (define-public ktsuss
>  (define-public aide
>    (package
>      (name "aide")
> -    (version "0.16.2")
> +    (version "0.18.8")
>      (source
>       (origin
>         (method url-fetch)
>         (uri (string-append "https://github.com/aide/aide/releases/download/v"
>                             version "/aide-" version ".tar.gz"))
>         (sha256
> -        (base32 "15xp47sz7kk1ciffw3f5xw2jg2mb2lqrbr3q6p4bkbz5dap9iy8p"))))
> +        (base32 "0q1sp0vwrwbmw6ymw1kwd4i8walijwppa0dq61b2qzni6b32srhn"))))
>      (build-system gnu-build-system)
>      (native-inputs
> -     (list bison flex))
> +     (list bison flex pkg-config))
>      (inputs
>       (list libgcrypt
>             libgpg-error
>             libmhash
> -           `(,pcre "static")
> -           pcre
> +           pcre2
>             `(,zlib "static")
>             zlib))
>      (synopsis "File and directory integrity checker")
>
> base-commit: dc8fb5672464b6386f6b4b94723f9b36edc4e625

hello, when i try 'aide -i', will report 
  ERROR: cannot open config file '/gnu/store/crq4phhak3pw3ihi03ywmy811qnihyx3-aide-0.18.8/etc/aide.conf': No such file or directory

can you fix it? i think it should /etc/aide.conf
Artyom V. Poptsov May 29, 2024, 7:37 p.m. UTC | #2
Hello Zheng Junjie,

thank you for reviewing my patch!

> can you fix it? i think it should /etc/aide.conf

Yes, I specified this as the path for the default configuration file.
But it should be created by the end user.

Also I've enabled some features for "aide" as it was done in Nix.[1]

Please find the second version of my patch attached to the issue.

Thanks,
- avp

References:
1. https://github.com/NixOS/nixpkgs/blob/f7a63cf975cc66559d5f488ffe6367c987a79826/pkgs/tools/security/aide/default.nix#L16
diff mbox series

Patch

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index bae9ee1308..4d4fbf55ac 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -234,23 +234,22 @@  (define-public ktsuss
 (define-public aide
   (package
     (name "aide")
-    (version "0.16.2")
+    (version "0.18.8")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://github.com/aide/aide/releases/download/v"
                            version "/aide-" version ".tar.gz"))
        (sha256
-        (base32 "15xp47sz7kk1ciffw3f5xw2jg2mb2lqrbr3q6p4bkbz5dap9iy8p"))))
+        (base32 "0q1sp0vwrwbmw6ymw1kwd4i8walijwppa0dq61b2qzni6b32srhn"))))
     (build-system gnu-build-system)
     (native-inputs
-     (list bison flex))
+     (list bison flex pkg-config))
     (inputs
      (list libgcrypt
            libgpg-error
            libmhash
-           `(,pcre "static")
-           pcre
+           pcre2
            `(,zlib "static")
            zlib))
     (synopsis "File and directory integrity checker")