diff mbox series

[bug#59667] gnu: openrgb: Update to 0.8.

Message ID bfc070852ca760b6f1a5dfe7873fc30b3ba0c145.1669683988.git.kaelyn.alexi@protonmail.com
State New
Headers show
Series [bug#59667] gnu: openrgb: Update to 0.8. | expand

Commit Message

Kaelyn Takata Nov. 29, 2022, 1:09 a.m. UTC
* gnu/packages/hardware.scm (openrgb): Update to 0.8.
[native-inputs]: Add qttools-5 for generating translations.
---
 gnu/packages/hardware.scm | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)


base-commit: 3cff7bfa9b46f1b73381df79a6f2aaa55a332126
--
2.38.1

Comments

John Kehayias Nov. 29, 2022, 2:29 a.m. UTC | #1
Hi Kaelyn,

LGTM. I've had a locally updated package for some time that needed the
same change (qttools-5). I saw some packages add a comment that this
native-input is needed for lrelease (true here), but not sure if that is
required.

Thanks!
John
Efraim Flashner Dec. 1, 2022, 8:48 a.m. UTC | #2
Thanks. I followed up with a patch to unbundle more of the libraries.
Patch pushed!
diff mbox series

Patch

diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index f392bb8c16..9da2b4ad29 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -998,7 +998,7 @@  (define-public openhmd
 (define-public openrgb
   (package
     (name "openrgb")
-    (version "0.7")
+    (version "0.8")
     (source
      (origin
        (method git-fetch)
@@ -1007,7 +1007,7 @@  (define-public openrgb
              (commit (string-append "release_" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0xhfaz0b74nfnh7il2cz5c0338xlzay00g6hc2h3lsncarj8d5n7"))
+        (base32 "1yz7sdrjcxajm1zpa5djinmych5dvck0r1fvk0x5qmk87va4p9z3"))
        (patches
         (search-patches "openrgb-unbundle-hueplusplus.patch"))
        (modules '((guix build utils)))
@@ -1044,7 +1044,8 @@  (define-public openrgb
            mbedtls-apache
            qtbase-5))
     (native-inputs
-     (list pkg-config))
+     (list pkg-config
+           qttools-5))
     (synopsis "RGB lighting control")
     (description
      "OpenRGB is lighting control that doesn't depend on manufacturer software.