diff mbox series

[bug#67067] gnu: nkf: fix cross-compilation.

Message ID bf967d57907abceb6a9b3a17f6ccaf24eecfc161.1699696144.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series [bug#67067] gnu: nkf: fix cross-compilation. | expand

Commit Message

Z572 Nov. 11, 2023, 9:49 a.m. UTC
* gnu/packages/textutils.scm (nkf): fix cross-compilation.
[arguments]: use Gexp and CC-FOR-TARGET.

Change-Id: Idd2cbdd89d4ce2feb484a6005e06f1eba491feea
---
 gnu/packages/textutils.scm | 16 +++++++++-------
 1 file changed, 9 insertions(+), 7 deletions(-)


base-commit: 61c527227ceebdad8da2d52214b253a48323cbb9

Comments

Mathieu Othacehe Nov. 25, 2023, 1:34 p.m. UTC | #1
> * gnu/packages/textutils.scm (nkf): fix cross-compilation.

Applied, thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 41a34b6c4e..801d8fd8ad 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -27,6 +27,7 @@ 
 ;;; Copyright © 2022 Gabriel Wicki <gabriel@erlikon.ch>
 ;;; Copyright © 2023 Reza Housseini <reza@housseini.me>
 ;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1289,13 +1290,14 @@  (define-public nkf
                   "0anw0knr1iy4p9w3d3b3pbwzh1c43p1i2q4c28kw9zviw8kx2rly"))))
       (build-system gnu-build-system)
       (arguments
-       `(#:tests? #f ; test for perl module
-         #:make-flags (list "CC=gcc" "CFLAGS=-O2 -Wall -pedantic"
-                            (string-append "prefix=" %output)
-                            "MKDIR=mkdir -p")
-         #:phases
-         (modify-phases %standard-phases
-           (delete 'configure)))) ; No ./configure script
+       (list #:tests? #f ; test for perl module
+             #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+                                  "CFLAGS=-O2 -Wall -pedantic"
+                                  (string-append "prefix=" #$output)
+                                  "MKDIR=mkdir -p")
+             #:phases
+             #~(modify-phases %standard-phases
+                 (delete 'configure)))) ; No ./configure script
       (home-page "https://ja.osdn.net/projects/nkf/")
       (synopsis "Network Kanji Filter")
       (description "Nkf is yet another kanji code converter among networks,