[bug#77322,v2] gnu: profanity: Update to 0.15.0.
Commit Message
From: Ashish SHUKLA <ashish.is@lostca.se>
* gnu/packages/messaging.scm (profanity): Update to 0.15.0.
[arguments]<#:phases>: Add patch-python-plugins phase.
Change-Id: I654a9648d973653fd44b19fcacd822bbb0570fd9
---
Hi,
Revising this patch with the definition of Py_XDECREF macro[0], as it's upstream.
[0] https://github.com/python/cpython/blob/3.10/Include/object.h#L571
Thanks!
gnu/packages/messaging.scm | 14 +++++++++++---
1 file changed, 11 insertions(+), 3 deletions(-)
base-commit: 2eb22e3d0f8013e438813b1a2c5f8b1e020fcde2
@@ -2246,7 +2246,7 @@ (define-public libstrophe
(define-public profanity
(package
(name "profanity")
- (version "0.14.0")
+ (version "0.15.0")
(source
(origin
(method url-fetch)
@@ -2255,7 +2255,7 @@ (define-public profanity
version ".tar.gz"))
(sha256
(base32
- "0zygsxxwdxmpppr7vyzi2r7d854yjl6918w0lrs7k41iib9zy8zx"))))
+ "1yy7x9ycqg6c65k66z47p8mvj48qc0pa4as1lk1agj8ffn7mg7sa"))))
(build-system glib-or-gtk-build-system)
(arguments
`(#:configure-flags
@@ -2268,7 +2268,15 @@ (define-public profanity
"--enable-otr"
"--enable-pgp"
"--enable-omemo"
- "--enable-icons-and-clipboard")))
+ "--enable-icons-and-clipboard")
+ #:phases
+ ,#~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-python-plugins
+ (lambda _
+ ;; Py_XDECREF is a macro in Python 3.10
+ (substitute* "src/plugins/python_plugins.c"
+ (("Py_XDECREF")
+ "_Py_XDECREF")))))))
(native-inputs
(list autoconf
autoconf-archive