diff mbox series

[bug#69654,1/3] gnu: Add go-github-com-jbenet-goprocess.

Message ID bf6398d3694c7518c3ce660362cdde950a828820.1709921226.git.poptsov.artyom@gmail.com
State New
Headers show
Series Add go-github-com-jbenet packages. | expand

Commit Message

Artyom V. Poptsov March 8, 2024, 6:23 p.m. UTC
* gnu/packages/golang-xyz.scm (go-github-com-jbenet-goprocess): New variable.

Change-Id: I5683a9e0df7bb1a17b2e813ab6c611f0b6c2ea9c
---
 gnu/packages/golang-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 0b3db6e379..7e71dca14c 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -987,6 +987,32 @@  (define-public go-github-com-hhrutter-tiff
 @end itemize")
     (license license:bsd-3)))
 
+(define-public go-github-com-jbenet-goprocess
+  (package
+    (name "go-github-com-jbenet-goprocess")
+    (version "0.1.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/jbenet/goprocess")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1z4a5skx9kh2c727pc6zz0vhf9v8acd320s7z0f1kwy3y1nbdhjk"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/jbenet/goprocess"))
+    (home-page "https://github.com/jbenet/goprocess")
+    (synopsis "Manage process life cycles in Go")
+    (description
+     "@code{goprocess} introduces a way to manage process lifecycles in
+Go.  It is much like @code{go.net/context} (it actually uses a Context), but it is
+more like a Context-WaitGroup hybrid.  @code{goprocess} is about being able to start
+and stop units of work, which may receive @code{Close} signals from many clients.")
+    (license license:expat)))
+
 (define-public go-github-com-jinzhu-copier
   (package
     (name "go-github-com-jinzhu-copier")