diff mbox series

[bug#73021,v3] gnu: Add gnudos.

Message ID bf5d14c9a9cb36be983a78422162ffe3290c6aff.1725434616.git.atai@atai.org
State New
Headers show
Series [bug#73021,v3] gnu: Add gnudos. | expand

Commit Message

Andy Tai Sept. 4, 2024, 7:24 a.m. UTC
* gnu/packages/mc.scm (gnudos): New variable.

Change-Id: I03a101be81bba3e4fdf8e11a7b4a799b92f86ad0
---
 gnu/packages/mc.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)


base-commit: 7fa9df431e9423e2b79c8c520de1d0ef7aed910d

Comments

Andy Tai Sept. 17, 2024, 11:29 p.m. UTC | #1
patch passed QA
https://issues.guix.gnu.org/73021
diff mbox series

Patch

diff --git a/gnu/packages/mc.scm b/gnu/packages/mc.scm
index 8cf760ac53..bc3a3e8fed 100644
--- a/gnu/packages/mc.scm
+++ b/gnu/packages/mc.scm
@@ -120,3 +120,26 @@  (define-public mc
 FTP or FISH.  It also includes a powerful text editor for opening text
 files.")
     (license gpl3+)))
+
+
+(define-public gnudos
+  (package
+    (name "gnudos")
+    (version "2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://gnu/gnudos/gnudos-" version ".tar.gz"))
+       (sha256
+        (base32 "06n4n6j7w6f54akmqqmsrbxv5rj6xairc6yskm33ag2ar7w8hz48"))))
+    (build-system gnu-build-system)
+    (propagated-inputs (list ncurses))
+    (home-page "https://www.gnu.org/software/gnudos/")
+    (synopsis "MS-DOS-like file manager, editor, and other tools")
+    (description
+     "GnuDOS is a set of programs designed to help new users of the GNU
+system in growing accustomed to the system, particularly users who might be
+coming from a DOS background.  It consists of a file manager, a text editor
+and a form designer for the console as well as a core library for building
+similar utilities.")
+    (license gpl3+)))