[bug#77975,28/32] gnu: Add java-cds-healpix.
Commit Message
* gnu/packages/astronomy.scm (java-cds-healpix): New variable.
Change-Id: Ie7f19463c440c87f34e4ad6d8a4d2cdf0c9bdd72
---
gnu/packages/astronomy.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)
@@ -109,6 +109,7 @@ (define-module (gnu packages astronomy)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
#:use-module (gnu packages)
+ #:use-module (guix build-system ant)
#:use-module (guix build-system cmake)
#:use-module (guix build-system copy)
#:use-module (guix build-system gnu)
@@ -1096,6 +1097,35 @@ (define-public indi
;; Default version of INDI..
indi-1.9)
+(define-public java-cds-healpix
+ ;; XXX: Upstream bundles java-commons-math3 available in Guix, find out how
+ ;; to use the system package instead of it.
+ (package
+ (name "java-cds-healpix")
+ (version "0.30.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cds-astro/cds-healpix-java")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1wi5ni6j0rvjyhz80g1gglxdimf7gnfa1kx8a3c2przzbwya0j8d"))))
+ (build-system ant-build-system)
+ (arguments
+ (list
+ #:jar-name "cdshealpix.jar"
+ #:source-dir "src/main/java/cds/healpix"
+ #:test-dir "src/test"))
+ (home-page "https://github.com/cds-astro/cds-healpix-java")
+ (synopsis "CDS HEALPix library in Java")
+ (description
+ "This package provides a @acronym{Centre de Données astronomiques de
+Strasbourg, CDS} implementation in Java of the @acronym{Hierarchical Equal
+Area isoLatitude Pixelization of a sphere , HEALPix} tesselation.")
+ (license license:bsd-3)))
+
(define-public iraf-community
(package
(name "iraf-community")